Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I live in Portugal.

I own a 2004 W203 C220 CDi estate, my mother owns a 2006 C220 CDi saloon (W203) and my step father has just bought a 2002 C220 CDi saloon.

His is the problem.

Bought second hand, the car has an "Audio 30 APS" header unit installed.

Firstly, the display is not very good, with missing pixels etc.
Is there any way to renew this?
Does anyone have a spare LCD that they might be willing to part with?~

Secondly the car is also fitted with a Mercedes original mobile phone attachment for Nokia 6210.
I have put a Nokia 6310i phone in it with version 5.7 of the Nokia software installed (the book says version 4.36 or newer) and the only thing that fundtions on the phone is the charging of the battery. The functions on the steering wheel have no effect and the dashboard display simply says Tel: or when I push a button on the steering wheel "PROCESSING". I know that the phone is fundtioning properly on its own, but when calls are received they cannot be answered using the Mercedes built-in functions, the radio keeps on coming out of the steering wheel and I cannot hear anyone, nor them me. Am I doing something wrong?

Finally does anyone have a copy of the instruction booklet for the "Audio 30 APS" in English that they could scan and send to me as a PDF?

In advance, I thank you all for your help.

Mark
 

·
Registered
222.132 & 221.122 & 213.050 & 906.633
Joined
·
10,425 Posts
The SW version 4.36 should refer to Nokia 6210 but 5.7 on a 6310i should be fine.

A bit odd if it says processing when pressing a button. The phone interface box is likely too old for the 6310i model but it normally should say "no phone".

Can you confirm that it works OK with a Nokia 6210?
 
1 - 2 of 2 Posts
Top