Mercedes-Benz Forum banner

201 - 218 of 218 Posts

·
Registered
1999 SL600 | 2001 SL500 (sold)
Joined
·
1,141 Posts
So I managed to get it working by downloading DieTRih's solution for HHTWIN (google his name if someone needs this in the future)
Can you please tell me what and where this solution is? I tried searching and searching DieTRih’s name and found nothing
 

·
Outstanding Contributor , SDS Guru
1998 MB E300TD, 1997 MB E36 AMG, 2001 MB E55 AMG. 2011 BMW 335d
Joined
·
6,064 Posts
He's over there in mhhauto forum. You have to pay the forum to become a member before you can download his files.
 

·
Registered
1999 SL600 | 2001 SL500 (sold)
Joined
·
1,141 Posts
He's over there in mhhauto forum. You have to pay the forum to become a member before you can download his files.
Do you have an hhtwin download that has r129 or have access to the fix files? Or know someone who has them and isn't trying to leach money just for me to be able to diagnose my own car??? (which all of us are doing with pirated software so paying for a simple fix is ridiculous)
 

·
Moderator
93 SL500, 95 SL320, 96 S320, 98 S500, 2002 E320 4Matic Wagon & A little 91 5.0 FORD Mustang
Joined
·
8,715 Posts
It is like $20 for a ONE time to pay for the site as he is one-man gang....

By the way, did you load the version Bobterry posted? or you had another version? I checked mine, and it does not have the R129 also, and I have Chinese one, and will check it..

Easy, don't get all fussy...

Martin
 

·
Registered
1999 SL600 | 2001 SL500 (sold)
Joined
·
1,141 Posts
It is like $20 for a ONE time to pay for the site as he is one-man gang....

By the way, did you load the version Bobterry posted? or you had another version? I checked mine, and it does not have the R129 also, and I have Chinese one, and will check it..

Easy, don't get all fussy...

Martin
Yup I’m using a version he linked me some time back and I think it’s the same as the one in his signature and the thread he made.
 

·
Moderator
93 SL500, 95 SL320, 96 S320, 98 S500, 2002 E320 4Matic Wagon & A little 91 5.0 FORD Mustang
Joined
·
8,715 Posts
The Chinese one I have is tied to Xentry, but the stand-alone one is the one I have been using for years, but i never read the codes of the R129s, and yesterday it was no-go on the menu-not there? Mine shows this....

Screenshot010.jpg
Screenshot011.jpg


I think I have something else that I got years ago... I want it to work as I'm building a XP machine right now with the bobterry system as I want to read off the communication protocols to the multiplexer, and my current version working Win7-32bit I would have a harder time than a XP version.

I'm searching for one

Martin
 

·
Moderator
93 SL500, 95 SL320, 96 S320, 98 S500, 2002 E320 4Matic Wagon & A little 91 5.0 FORD Mustang
Joined
·
8,715 Posts
You may want to try this as buddy of mine gave it to me, but it does not reflect exactly what I have in my Windows-7, but i found the file:

Go to c:\Program Files\Mercedes-Benz\HHT\PKW

Right click on HHTPKW.exe
Select "Create shortcut". Put it on the desktop.

Right click the new shortcut. Select Properties.
On the line labeled Target: , add the following to the very end of the line:
-b129

There has to be a space between the rest of the existing line, and the -b129

So it should look like ...\HHTPKW.EXE" -b129

You can also create another shortcut and replace the -b129 with -b140 for the W140.

Or you can copy and paste this entire line into Target, replacing what's already there:

"C:\Program Files\Mercedes-Benz\HHT\PKW\HHTPKW.EXE" -b129

Note that the quotes MUST remain.

My HHTPKW.EXE was not in that Program Files section, but at the root of the c drive, but you can find exactly where the file is located by Right-Clicking the HHT short cut, and scrolling to "Open File Location", and it will take you there. MINE did NOT have the quotes either, so I left them out. I will try it on the car later as HHT will not go past the initializing menu if it is not connected to the car.

Martin
 

Attachments

·
Registered
1999 SL600 | 2001 SL500 (sold)
Joined
·
1,141 Posts
You may want to try this as buddy of mine gave it to me, but it does not reflect exactly what I have in my Windows-7, but i found the file:

Go to c:\Program Files\Mercedes-Benz\HHT\PKW

Right click on HHTPKW.exe
Select "Create shortcut". Put it on the desktop.

Right click the new shortcut. Select Properties.
On the line labeled Target: , add the following to the very end of the line:
-b129

There has to be a space between the rest of the existing line, and the -b129

So it should look like ...\HHTPKW.EXE" -b129

You can also create another shortcut and replace the -b129 with -b140 for the W140.

Or you can copy and paste this entire line into Target, replacing what's already there:

"C:\Program Files\Mercedes-Benz\HHT\PKW\HHTPKW.EXE" -b129

Note that the quotes MUST remain.
It worked! I found this hidden second hhtwin executable and did the target stuff and boom I can diagnose r129! Though this exe only launches straight to r129 , or maybe it auto detects the chassis? Who knows.

anyways thanks for the successful suggestion
 

·
Moderator
93 SL500, 95 SL320, 96 S320, 98 S500, 2002 E320 4Matic Wagon & A little 91 5.0 FORD Mustang
Joined
·
8,715 Posts
Super that it worked, but I'm still looking for one with R129 in the listing...

Martin
 

·
Moderator
93 SL500, 95 SL320, 96 S320, 98 S500, 2002 E320 4Matic Wagon & A little 91 5.0 FORD Mustang
Joined
·
8,715 Posts
@sushipaste

Where did you get your Multiplexer from? you have a C3? or C4? Got a link!

Thanks,

Martin
 

·
Registered
2005 CLK320
Joined
·
680 Posts
@sushipaste

Where did you get your Multiplexer from? you have a C3? or C4? Got a link!

Thanks,

Martin
If you use hhtwin stand alone it has to be a c3 stand alone only supports rs232.
I would still recommend a c4 with 2016 xentry the installation is a bit more challenging but than you can work on newer models as well.

Sent from my SM-G892A using Tapatalk
 

·
Registered
1999 SL600 | 2001 SL500 (sold)
Joined
·
1,141 Posts

·
Registered
Buncha W124's
Joined
·
2,291 Posts
Running HHTWIN alone with your r129 trick on a windows xp virtual machine. Multiplexer is C3
Do you mean running HHTWIN wihthout DAS/Xentry software installed? Just the HHT WIN executable and C3 mux?
 

·
Registered
Buncha W124's
Joined
·
2,291 Posts
Yup just the straight HHTWIN executable and c3 multiplexer. I used MAVA's trick here to make things work
That is AWESOME. What OS are you using, and does your laptop have a native serial port? Edit - I see you are using XP in a virtual machine, but the same questions apply otherwise.

I'd love to see if we can make HHT WIN standalone on Windows 10 with a USB-to-serial converter, and not have to use old laptops / old OS. Still, HHT WIN without all the headaches of DAS licensing would be fantastic!
 

·
Registered
1999 SL600 | 2001 SL500 (sold)
Joined
·
1,141 Posts
That is AWESOME. What OS are you using, and does your laptop have a native serial port? Edit - I see you are using XP in a virtual machine, but the same questions apply otherwise.

I'd love to see if we can make HHT WIN standalone on Windows 10 with a USB-to-serial converter, and not have to use old laptops / old OS. Still, HHT WIN without all the headaches of DAS licensing would be fantastic!
Apparently HHT only runs on XP. Yes laptop has serial port
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550 FORMER: C300, ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
21,833 Posts
201 - 218 of 218 Posts
Top