Mercedes-Benz Forum banner

1 - 19 of 19 Posts

·
Registered
2000 ML320
Joined
·
278 Posts
Discussion Starter #1
So I am messing around with my dell laptop (vista 32bit) + C4 multiplexer and it's pretty cool. I was able to code in "trip computer present" and now my glass break sensor works!!! Tested it by clapping my hands in front of the sensor! I notice that when I run HHTWIN it does not list w163. However, when I try to access lets say the instrument cluster via Xentry I get this message "HHTWIN not available." I am trying to code the cluster to enable the illumination of the green fog light indicator. Does anyone have any experience with this?

2019.09 Xentry DAS
 

·
Premium Member
1999 ML430
Joined
·
1,739 Posts
I had my green fog light indicator enabled many years ago by one of the MB dealers close by. Took all of about five minutes and it was just a few keystrokes on the keyboard. I was having some other work done at the time under warranty and there was no charge for the service.
These are the inboard light receptacles on the headlights. I believe they were H3's for that position. I use them all the time for DRL's. The headlight switch must be in the 2nd position for them to function along with the amber outboard lights
 

·
Registered
1999 ML320
Joined
·
145 Posts
Your xentry install is either messed up by viruses, bad install (Chinese garbage) or incomplete. Hht-win installs automatically when installing xentry x32. Or it used to up to 2018. Also hht-win only works to cars until 2000, after that all is done in das. If you want I can take a look via TeamViewer and tell you exactly what the problem is.

Update : I read your post again. I see you have xentry 2019. In the beginning of 2019 xentry started to install only on the x64 windows systems. Some folks on some forums tweaked the installer to work on x32 systems but Mercedes completely removed hht-win from it. Hht-win is a 16 bit app and only works on windows x32, hence the lack of it in 2019 xentry. Your system does not have hht-win at all. Contact your xentry seller, some are smart enough to know how to add hht-win. Most aren't. Good luck
 

·
Registered
2000 ML320
Joined
·
278 Posts
Discussion Starter #4
@springerfever
I already had my fog lights enabled when I retrofitted my new front bumper. The only thing I didn't do/forgot was have the green fog light indicator coded in. So although the front fogs will the green light on my cluster will not illuminate.

@ciprianmuresan

That would be awesome if you can do that. The software is installed on a mechanical HD and is a little slow. Teamviewer is already installed on it.
 

·
Registered
Dallas, Texas
Joined
·
7,720 Posts
Something wrong with the setup. Xentry should drop do DAS. DAS will check diagnostic version of module and stay there or drop to HHT-WIN.
 

·
Registered
Dallas, Texas
Joined
·
7,720 Posts
@springerfever
I already had my fog lights enabled when I retrofitted my new front bumper. The only thing I didn't do/forgot was have the green fog light indicator coded in. So although the front fogs will the green light on my cluster will not illuminate.

@ciprianmuresan

That would be awesome if you can do that. The software is installed on a mechanical HD and is a little slow. Teamviewer is already installed on it.
Have you girls met for a beer before?

What if function "Irrevocably erase all keys" is invoked?
 

·
Registered
2000 ML320
Joined
·
278 Posts
Discussion Starter #8
Your xentry install is either messed up by viruses, bad install (Chinese garbage) or incomplete. Hht-win installs automatically when installing xentry x32. Or it used to up to 2018. Also hht-win only works to cars until 2000, after that all is done in das. If you want I can take a look via TeamViewer and tell you exactly what the problem is.

Update : I read your post again. I see you have xentry 2019. In the beginning of 2019 xentry started to install only on the x64 windows systems. Some folks on some forums tweaked the installer to work on x32 systems but Mercedes completely removed hht-win from it. Hht-win is a 16 bit app and only works on windows x32, hence the lack of it in 2019 xentry. Your system does not have hht-win at all. Contact your xentry seller, some are smart enough to know how to add hht-win. Most aren't. Good luck
I see, what version of Xentry should I get? But I see the hht-win on my desktop. The applications runs. You think it might have to do with my current version of xentry not communicating with HHTWIN?
From the system and data it says
25.15.2.3 XENTRY DIAGNOSIS
09/2019 DATA RELEASE OF XENTRY DIAGNOSIS
1.3.5.0 SOFTWARE VERSION OF ASAM SERVER (CASESAR)
8.17.10 SOFT VERSION OF ASRAM SEVER (SOFTING)
 

·
Registered
1999 ML320
Joined
·
145 Posts
I see, what version of Xentry should I get? But I see the hht-win on my desktop. The applications runs. You think it might have to do with my current version of xentry not communicating with HHTWIN?
From the system and data it says
25.15.2.3 XENTRY DIAGNOSIS
09/2019 DATA RELEASE OF XENTRY DIAGNOSIS
1.3.5.0 SOFTWARE VERSION OF ASAM SERVER (CASESAR)
8.17.10 SOFT VERSION OF ASRAM SEVER (SOFTING)
If the hht-win is on your desktop then it's installed. The person who installed it needs to edit hht-win.ini to connect it to xentry, so when das calls hht-win, it will start automatically. I bet all my lunch money that's an aliexpress/eBay install.
 

·
Registered
1999 ML320
Joined
·
145 Posts
Ok, I can't connect to your TeamViewer. Says you don't have it turned on. I'm going to bed. I'm doing more "delete all keys" tomorrow lol. Good luck with everything, dude.
 

·
Registered
Dallas, Texas
Joined
·
7,720 Posts
Lol yeah, I make a hobby out of tricking forum members to give me their TeamViewer to delete their keys. Busted!
My response was not directed at you but rather towards new owners of DAS.

Like any new toy it brings out curiosity. Some of those installations come with developer mode and things can go wrong really fast.
Couple of examples:


 

·
Registered
1999 ML320
Joined
·
145 Posts
My response was not directed at you but rather towards new owners of DAS.

Like any new toy it brings out curiosity. Some of those installations come with developer mode and things can go wrong really fast.
Couple of examples:


Absolutely. I agree 100%. I get asked a lot to fix stuff inexperienced xentry users messed up. On a weekly basis actually. I apologize for getting your message the wrong way. Long day yesterday, 5 AM start. Problem is accessibility. Nowadays xentry is available on eBay and aliexpress for anyone. And most people think that if they buy it they can eliminate their mechanics with 20-30 years of experience. On top of that the Chinese installs and clones are horrendous. There's a reason why they are so cheap (couple of hundreds) and why an original install can get all the way up to 36k. It will all come to a stop this year with 09.2020 version, after that everything will be moved online like Chrysler does it. Xentry is not as simple as it seems. It's not a magic wand
 

·
Registered
2000 ML320
Joined
·
278 Posts
Discussion Starter #15
Ok friends!!! I did it!!!!!! From the bowels of the internet I found the solution! As stated before DAS was unable to locate HHTWIN and I kept getting "HHTWIN not available." So what I was able to figure out was that obviously I had a poorly installed xentry setup and I needed a few files to get it working right. I was able to find "hht_call.s" and and various other files that someone graciously uploaded. All I did was copy and paste to the correct directories and boom DAS was able to call up HHTWIN. From there I was able to activate the green fog light activation on the instrument cluster. So there you have it.
2626172
 

·
Registered
1999 ML320
Joined
·
145 Posts
Ok friends!!! I did it!!!!!! From the bowels of the internet I found the solution! As stated before DAS was unable to locate HHTWIN and I kept getting "HHTWIN not available." So what I was able to figure out was that obviously I had a poorly installed xentry setup and I needed a few files to get it working right. I was able to find "hht_call.s" and and various other files that someone graciously uploaded. All I did was copy and paste to the correct directories and boom DAS was able to call up HHTWIN. From there I was able to activate the green fog light activation on the instrument cluster. So there you have it. View attachment 2626172
Outstanding job!
 

·
Registered
W203 C320 Auto w2k
Joined
·
16 Posts
@LegendaryATM,
very cool. I have the exact same problem with the chinese 2019 Xentry, too. Because the solution is so fresh, could you please be so kind and tell us the URLs where to find the files and/or solution? Or can you please send me the files (in this case I would tell you my mail adress by PM).
Thank you...Daniel
 

·
Registered
W203 C320 Auto w2k
Joined
·
16 Posts
1 - 19 of 19 Posts
Top