Mercedes-Benz Forum banner

Hey piotr everything looks good now!

647 Views 3 Replies 1 Participant Last post by  Guest (MBNZ)
My engine temp has come back down, even on hot days doing congested city driving the car still holds a good 85C. I also replaced the front speakers, HUGE improvment! I put some pioneer 4's in, just a direct replacement. Getting the driver's side one out was a pain, but I got it.
1 - 4 of 4 Posts

· Registered
Joined
·
36,559 Posts
Discussion Starter · #3 ·
Absolutely nothing! The engine temp just came back to normal on its own. I have found one verified problem w/ the CC. The actuator motor is dead. I am guessing that has killed the amp as well. Nothing I'm in a hurry to fix anyway. When I am going to take a long trip I'll fix it.<br> <br> I also have finally replaced all my stereo equipment in the car. Large improvment over the stock, but could be better. I am satisfied with it.
 

· Registered
Joined
·
36,559 Posts
Discussion Starter · #4 ·
Absolutely nothing! The engine temp just came back to normal on its own. I have found one verified problem w/ the CC. The actuator motor is dead. I am guessing that has killed the amp as well. Nothing I'm in a hurry to fix anyway. When I am going to take a long trip I'll fix it.<br> <br> I also have finally replaced all my stereo equipment in the car. Large improvment over the stock, but could be better. I am satisfied with it.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top