Mercedes-Benz Forum banner
1 - 18 of 18 Posts

·
Registered
1988 merc 190E
Joined
·
66 Posts
Discussion Starter · #1 ·
Decent body, black color. needs a fuel pressure regulator at the least- the vacuum nub is broken off and it's not letting fuel past.



like the site a lot. nice to see all the useful tips!
 

·
Registered
1988 merc 190E
Joined
·
66 Posts
Discussion Starter · #6 ·
man those lights look hot. yeah black is definatly a nice color. so i got a new fuel pressure reg (well a used one) and put it in, but what i misdiagnosed earlier is that i have no pressure up to it (it needed replacement anyway). I can not hear the fuel pump (supposed to be in the trunk right?) when i switch on the key. i checked the relay and didnt see any burnt circuits- i am not sure if i got the right one as it didnt look like the picture posted on the repair a relay thread, but it matched up to the part # from the online manual.... any ideas? what else could it be- the pump?

Thanks for all the input guys!
 

·
Registered
1991 300SE
Joined
·
1,435 Posts
ricehunter - 4/5/2006 9:40 AM

just put my euros in they look great a very easy upgrade a definite must for your 190
Very nice ricehunter! BTW, I was gonna order some new Euros for my W201. Probably from the same place I bought for my W126. (Katmac, TYC brand) Where did you buy your euros from and for how much? I think a set from Katmac is $249.00 with new connectors.
 

·
Registered
190E, 993
Joined
·
552 Posts
Scott-thundercat - 4/5/2006 1:26 PM

man those lights look hot. yeah black is definatly a nice color. so i got a new fuel pressure reg (well a used one) and put it in, but what i misdiagnosed earlier is that i have no pressure up to it (it needed replacement anyway). I can not hear the fuel pump (supposed to be in the trunk right?)

the pump isn't in the trunk, its under the car. a plastic panel is protecting it.
 

·
Registered
1989 190E 2.6
Joined
·
16 Posts
Jammerkiller - 4/5/2006 4:51 PM

ricehunter - 4/5/2006 9:40 AM

just put my euros in they look great a very easy upgrade a definite must for your 190
Very nice ricehunter! BTW, I was gonna order some new Euros for my W201. Probably from the same place I bought for my W126. (Katmac, TYC brand) Where did you buy your euros from and for how much? I think a set from Katmac is $249.00 with new connectors.
I bought them from import vision motors for $215.00 plus $50 to ship to canada plus an unexpected brokerage fee of $87(goverment needs there share) but I had to get my own connectors from the dealer only $4.45Cdn each.
 

·
Registered
1991 300SE
Joined
·
1,435 Posts
Cool. They are not too informative with any info on their lights like Katmac is. Oh, well. I decided to order from Katamc again. $262 for a pair with blue city lights and connectors. I'd like to compare once I get them in.[:)]
 

·
Registered
1989 190E 2.6
Joined
·
16 Posts
Jammerkiller - 4/6/2006 12:16 AM

Cool. They are not too informative with any info on their lights like Katmac is. Oh, well. I decided to order from Katamc again. $262 for a pair with blue city lights and connectors. I'd like to compare once I get them in.[:)]
No their not.When I got them there was no bulbs, no connectors, no wiring diagrams just the lamps.thats what you get when you try to save 47 bucks.looking forward to some of your pics
 

·
Registered
1988 merc 190E
Joined
·
66 Posts
Discussion Starter · #12 ·
well, in the quest for finding the lack of fuel fault- i jumpered terminals 30 and 87 where the fuel pump relay would go- and the pump didnt turn on though the jumper wire did have power..... any ideas? it's just eating me up that it wont run! i can use start fluid and it works great... oh well. please some ideas! is it the fuel pump? are there any fuses between there and the fuel pump that could be bad?
 

·
Registered
2008 Outback 2.5 XT, 2012 CNG Civic
Joined
·
1,768 Posts
Scott-thundercat - 4/3/2006 9:44 PM

Decent body, black color. needs a fuel pressure regulator at the least- the vacuum nub is broken off and it's not letting fuel past.



like the site a lot. nice to see all the useful tips!
nice ride. Welcome to the forum!
Sounds like your problem might be purely electrical though... if it runs, do you hear a clear buzzzzzzzz from the area where the fuel tank is?
 

·
Registered
1988 merc 190E
Joined
·
66 Posts
Discussion Starter · #14 ·
no buzz at all. i'm going to pull the pump and check to see if i hook it straight to the battery what happens... just to limit my choices
 

·
Registered
1991 300SE
Joined
·
1,435 Posts
ricehunter - 4/6/2006 5:46 AM

Jammerkiller - 4/6/2006 12:16 AM

Cool. They are not too informative with any info on their lights like Katmac is. Oh, well. I decided to order from Katamc again. $262 for a pair with blue city lights and connectors. I'd like to compare once I get them in.[:)]
No their not.When I got them there was no bulbs, no connectors, no wiring diagrams just the lamps.thats what you get when you try to save 47 bucks.looking forward to some of your pics
DAMN! That sucks! I'm glad I went with Katmac again. The set I got for the 300 came with H3/4's, city lights and wire, new 6-pin connectors and instructions.

Hope that's a lesson for others who are thinking of ordering Euros online.[:)]
 

·
Registered
1988 merc 190E
Joined
·
66 Posts
Discussion Starter · #16 ·
My god! i got the bitch running! replaced the fuel pump with one from a 300E... i've never seen a 2.3 Liter with an automatic be that powerful! i was spinning tires and everything! so much fun to drive! today was a sweet day- got 2 fuel pumps, a fuel filter and the other little thingy from pick and pull (off a 300E) and swapped in one of the pumps. started right up! drove it around and had a lot of fun!
 

·
Registered
2008 Outback 2.5 XT, 2012 CNG Civic
Joined
·
1,768 Posts
CONGRATS!!!!!![:D][:D][:D][:D][:D]
 

·
Registered
1991 300SE
Joined
·
1,435 Posts
Scott-thundercat - 4/7/2006 12:05 PM

My god! i got the bitch running! replaced the fuel pump with one from a 300E... i've never seen a 2.3 Liter with an automatic be that powerful! i was spinning tires and everything! so much fun to drive! today was a sweet day- got 2 fuel pumps, a fuel filter and the other little thingy from pick and pull (off a 300E) and swapped in one of the pumps. started right up! drove it around and had a lot of fun!
Great job!!!! Glad to hear she is fixed.[:)]
 
1 - 18 of 18 Posts
Top