Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
2001 CLK320, 2004 C230 Coupe, 2000 C230 sport, 1998 SLK230
Joined
·
99 Posts
Discussion Starter #1
I've had issues with the car hesitating for a while. More so when you already have a little speed and then push it, it hesitates for a few seconds then goes but still might sputter here and there. It doesn't do it so much when just starting from a stop.
I had thought that I probably needed to replace the MAF sensor but because it does fine in most moderate driving, I've been putting it off. I have cleaned it a couple times.
But today when I was driving to work this car pulled out in front of me and because of traffic I had to get over and speed up quickly. I had to slow down behind the car and was going maybe 45 before I got over. But when I pushed it to pick up speed it hesitated like usual but I heard what sounded like 2 metal clicking or tapping noises about 1/2 a second apart in the middle of all the sputtering. I thought I had heard something like that before but wasn't sure. I could hear it more clear this time. It's hard to tell but it sounded like it came from underneath maybe around the transmission. The trans. has always shifted smooth otherwise and I haven't had any issues with it.
Does anyone know what it could be or have had this happen?
Any info would be greatly appreciated.
 

·
Registered
98 red 230 slk
Joined
·
454 Posts
Any codes? Could be Maf? K40 relay? Secondary aircheck valve? Camshaft mag? The list goes on.......
 

·
Registered
2001 SLK 320(217K Miles), 2002 E320 Special Edition(183K Miles)
Joined
·
3,467 Posts
Or unburnt gas igniting in the catalytic converter (the metal/clicking sound). Better check those codes since a cat is expensive.
I cannot believe that the CEL is not on with the symptoms you are describing. Is the bulb blown or are you just ignoring it? MAF cleaning does not really help - most of the time it's just a temporary measure.
 

·
Registered
2001 CLK320, 2004 C230 Coupe, 2000 C230 sport, 1998 SLK230
Joined
·
99 Posts
Discussion Starter #4 (Edited)
I've already replaced the camshaft sensor, the secondary air check valve, o2 sensor, and I checked the k40 relay and it looked just as it should. The CEL doesn't come on when it runs like that, it comes on at random times usually when it's running fine even when it's just idling and then will go off by itself after a few days. The last time it came on was at least a couple months ago and it went off in less than a week. I hadn't bothered to have it checked because it always said the same thing but I had it checked yesterday to see if it had any stored codes from before and they said there weren't any. I was really starting to think it was the catalytic converter so I took it to a small local shop today that I had heard good reviews about and they checked it and said they were bad. They said they can do two universal ones for $150 each, installed. That seems like it's about the cheapest I'll be able to do it. I looked online and a OEM one is $848 wholesale:eek:.
 

·
Registered
2001 SLK 320(217K Miles), 2002 E320 Special Edition(183K Miles)
Joined
·
3,467 Posts
They said they can do two universal ones for $150 each, installed. That seems like it's about the cheapest I'll be able to do it. I looked online and a OEM one is $848 wholesale:eek:.
You can also ask your MB dealer for a refurbished set. I got an OEM refurbished set from MB for my SLK 320 for $264. And on an SLK320 that is 3 catalytic converters, one of the front ones and both rears!
I ordered mine from parts dot com, which is actually a MB dealer, since they were $100 cheaper than my local MB dealer. Now of course the local MB dealer will not offer you refurbished on his own, you have to ask/demand it.

And BTW, I don't think those were actually refurbished parts, since the pipes had no nicks on them and they were totally shiny, even on the inside.
 

·
Registered
2001 CLK320, 2004 C230 Coupe, 2000 C230 sport, 1998 SLK230
Joined
·
99 Posts
Discussion Starter #6
Thanks for the tips Kobus. I called the dealership parts department and they said they couldn't get refurbished parts. I went to parts.com and couldn't find anything cheaper for the 230. I also called a Mercedes shop in Atlanta that I knew had installed some refurbished parts in my car for the previous owner and they said they couldn't get a refurbished converter.
So it looks like I'll be having that local shop replace them.
 

·
Registered
2001 CLK320, 2004 C230 Coupe, 2000 C230 sport, 1998 SLK230
Joined
·
99 Posts
Discussion Starter #7 (Edited)
Ok so I replaced the converters. The shop had told me that they were broken up and rattling. I asked to keep the old ones and after looking at them I don't see anything wrong with them so I kinda fell like I was screwed:mad:. But since I kept the old ones I should be able to make a good chunk of my money back on them at least. On top of that my car still has the same problems with misfiring. I took it to the shop because it had another episode but this time the CEL came on and it continued to run rough until I shut it off and back on then it was fine. The scanner said that cyl 2 misfired. Now I was thinking that maybe I needed to replace the ignition coils.
 

·
Registered
2001 CLK320, 2004 C230 Coupe, 2000 C230 sport, 1998 SLK230
Joined
·
99 Posts
Discussion Starter #8
I replaced the boot that goes with the ignition coil for cylinder 2 and that seems to have mixed the misfire problem. The CEL has been coming on more often now though always saying Secondary air injection system malfunction. I replaced the check valve probably about 40K ago or maybe more. Do you think it could have gone bad already? I was thinking of going ahead and replacing the other ignition coil boot since it kinda did look worn also and because it still doesn't seem to have as much power as it should. I had talked to the Service Supervisor at the dealership before I replaced the first boot because I was thinking about replacing all the wires and boots and wasn't sure how all the pieces went together and he said that all the spark plug boots are pretty sturdy and they usually only replace them if they misfire and only the one thats misfiring.
 
1 - 8 of 8 Posts
Top