Mercedes-Benz Forum banner
1 - 4 of 4 Posts

·
Registered
C230 2000
Joined
·
51 Posts
Discussion Starter · #1 ·
Well I just got my car fixed yesterday, changed MAF, changed spark plugs since cylinder 4 was misfiring, welded a peice of exhaust that was loose and I also got a shield tighten so it would stop making noise... Man was I happy! I got out and took it for a test drive, no more check engine, everytime was running real good... too good to be true...

Today, I get back in my car and guess what! my check engine light was back on... go to hell check engine light!!!!

I check my codes and I get

P0341 Camshaft Position Sensor Circuit Range/Performance
and
P0455 Evaporative Emission Control System Leak Detected (gross leak)

So now what, what did my car get into now!? :surrender:
 

·
Registered
2001 CLK55 AMG, 2002 C32 AMG
Joined
·
1,637 Posts
i would recommend clearing the codes and see what comes back, but it looks like you need a new camshaft postion sensor. this might cure your other code as well, but im not sure, they look like two seperate issues to me.
 

·
Registered
'99 2.3L Kompressor
Joined
·
1,944 Posts
Could you maybe have done something to the camshaft position sensor wiring while doing the other work?

Your avatar says you have a 2000 c230 and your sig says you have a 2002 c 230. Which is the problem vehicle?
 

·
Registered
C230 2000
Joined
·
51 Posts
Discussion Starter · #4 ·
Your avatar says you have a 2000 c230 and your sig says you have a 2002 c 230. Which is the problem vehicle?
My mistake, it is a 2000 C230!

And i did erase the codes and no more check engine :) problem fixed!
 
1 - 4 of 4 Posts
Top