Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
2003 CLK 320 (sold) 2004 CLK 500 Cabrio (sold) 2005 CLK 55
Joined
·
8 Posts
Discussion Starter #1
Last night I did a real stupid thing; I left my sunroof partially opened while I shopped inside a store. Before I came out, it begun raining and my interior got a tad bit wet. In fact, my vehicle would not start. I received a "Defective Display" error on the dash, the radio LED's were dimmly lit as well as the AC/Heat control display. The gear also would not disengage out of park. After about 2 hours of attempting to start my car it finally started. However, I had to manually unlock the gear lever out of park into drive mode my using a ball point pen as described in the owners manual. It appears this is called "limp mode" because the car remains in 2nd gear. I was able to "limp" home. This morning all my displays are currently visable and show no water residual; however the car is still will not disengage out of park without inserting the ball point pen. Does anyone know how to "reset" the dash display so that the error code may be removed? I hate to have it towed to Benz unless it's my only resort. Thanks!
 

·
Premium Member
CLK / ML
Joined
·
4,077 Posts
Yes unplug the battery. If this doesn't work, try resetting the FSS. The instructions ar...

Yes unplug the battery. If this doesn't work, try resetting the FSS. The instructions are in your manual.

Some faults(BAS, ESP, etc.) are also reset by doing the ff:

1. Turn key to on Position
2. Turn steering wheel counter clock wise all the way then clock wise all the way to the right.
3. Turn off
4. Start car
 
1 - 3 of 3 Posts
Top