Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
all bkack 1997 c280 sit on 18
Joined
·
23 Posts
Discussion Starter #1
ok guys i just go new rear wheel hub for my 97 c280 ,the old hub are 5 lug and the new one are 4 lug ,now checked the part on partstrain.com,ebay,partgeeks, all these site are showing the same 4 lug hub what should i do ,i have not tryed to install the new part :surrender:
 

·
Registered
2000 c230 Kompressor (Totalled 5/2012)
Joined
·
238 Posts
I checked a few parts sites and they all seem to show 4 lug hubs as well. This is very strange since the car obviously requires a 5-lug hub. I thought of another idea, which is to find a junk yard and see if you can get a hub off of a mercedes there. I think any hub from a w202 will work.

Just wondering, why does the hub need replacement anyways?
 

·
Registered
99 C280
Joined
·
233 Posts
Most likely the picture of the part you are looking at is just a generic picture.

The picture is not exactly correct, just showing a "hub", just not a Mercedes hub.
 

·
Premium Member
2004 CLK 240 Coupe
Joined
·
11,377 Posts
Most likely the picture of the part you are looking at is just a generic picture.

The picture is not exactly correct, just showing a "hub", just not a Mercedes hub.
The picture is correct in the WIS (Mercedes Workshop Manual on DVD)

When you enter the precise model, part, etc, the WIS provides details of the item you are searching for.

See below, where W202 is included on the title of this drawing.
 

Attachments

·
Registered
all bkack 1997 c280 sit on 18
Joined
·
23 Posts
Discussion Starter #9
the bearing are dad ,i have a real bad sound from the back wheel ,i had the same problem in the front i changed the bearing and the sound is gone now the back doing the same thing, the picture is not generic i have the part in my hand it the same as the picture,if the hub is the same as the front is super easy to do it took me long to take the wheel off then to replace the bearing
 
1 - 9 of 9 Posts
Top