Mercedes-Benz Forum banner
1 - 7 of 7 Posts

·
Registered
1989 560SEL
Joined
·
864 Posts
Discussion Starter · #1 ·
I know this is definately not the right place for this post but i still figured i'd ask since i know most of you know a lot about cars..

My brother has a 06 Mustang Pony package. So the problem is, the car will accelerate fine up til about 2K rpms but once it reachest past that the car sounds like its pretty much just revving and not accelerating as fast as it should be. In fact when i drove it, when its at say 6K Rpms its acting like its at 3 and just lags back. I think its his spark plugs but what the hell do i know.

Ontop of that he's able to pull the shifter out of third when he's driving w/o the clutch. Just slips out easily.

Any opinions?
 

·
Always Remembered RIP
1991 560SEC AMG
Joined
·
10,146 Posts
You said it is a 2006 model.

If it is still under the 3/36 factory warranty take it to the Ford dealer and let them deal with it.

Is the "Pony" package the "budget-breath" set up?
 

·
Premium Member
1987 560 sec impala metalflake over cream
Joined
·
1,130 Posts
taking it out of gear i think is normal? we used to be able to do it in most gears in the old days. with the right rpm you dont need much of the clutch engaged to slam it in either.but dif. eara, diff. cars,much younger. what kind of speed are you doin at 6 grand, maby thats all its rear is geard for? but its fords problem as stated befor,keep us informed
 

·
Registered
1989 560SEL
Joined
·
864 Posts
Discussion Starter · #4 ·
I know he's going to take it to ford but he's just been asking me what i think it is but i have no clue, figured you guys would have a better idea. But i know you can shift w/o the clutch if you're careful with it but his third gear u can just pop it out with your finger w/o any trouble at all.

And im just saying when the car gets pushed high into the RPM's its not responding back to it, it just keeps slowly going.
 

·
Premium Member
1987 560 sec impala metalflake over cream
Joined
·
1,130 Posts
im no mecanic, but sounds a bit like the X,s car it was something to do with the cats. she had new hiyandi. surprising no one else responded. must be out driving?
 

·
Registered
1989 560SEL
Joined
·
864 Posts
Discussion Starter · #6 ·
Alright well his clutch pretty much engages when its hardly pushed in, almost looks its not even being pushed in so assuming its the clutch doing this. I know he drives hard, it's only a year old car (was an 07 not 6) and he's got like more than 15K miles on it already.
 

·
Registered
1982 280 se aut. ecc. - sold
Joined
·
1,607 Posts
Manual trans?
Clutch is dead! your brother needs a new one!

gr J
 
1 - 7 of 7 Posts
Top