Mercedes-Benz Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1
Hope you can help me with this one!!<br> My '84 230TE recently cut out without warning and will not start again. Never had probs starting or running in the past (although it was showing signs of slight back preassure - some oil in air filter housing, but it ran fine). Local garage has checked there's a spark, fuel pump is ok, new starter motor and battery, enough fuel preasure for mechanical injection system etc. Still nothing, and they say they've run out of ideas!! Anyone got a clue what might be problem?? It turns over but not ignite. Ple send suggestions coz at the moment it's worthless and I was planning to sell it next month!!<br> Many thanks, Rich <br> PS - It had full Merc S/H till last year (currently 155k miles)and I'm only the 2nd owner. It's for sale in current state for £500 (Lewes, East Sussex)
 

·
Registered
Joined
·
0 Posts
Discussion Starter #2
I've got the same model that did the same thing. Check the rotor arm. If it's blackened, cracked, or similar, replace it. Only costs a couple of quid.<br> <br> What condition is the car in, colour, spec. etc. Wondering is it worth £500 or more.
 

·
Registered
Joined
·
0 Posts
Discussion Starter #3
My 230CE did the same thing and it turned out to be the fuel pump regulator. If you turn on the ignition you should hear the pump working and then stop, if not then this may be the promblem. Its located under the passenger side dashboard on the side above bonnet catch (three screws to remove plastic under side) . On mine I found a dry solder joint which just neaded re-soldering.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top