Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1
I need help please and as much input from anyone out there no matter how small or big it is. I want to thank you all in advance. I have a C240 2002, it only has 2700 miles on it. I noticed from the start that when i was driving in a straight line on an even road the car starts steeing to the right. Not a heavy steer but still. So i took it to the dealer and they did an allainment and a balance, that fixed the problem. Now i was able to drive and the car will go in straight line and after like maybe 10 sec start going to the left which is natural. Last week i bought 17inch chrome monoblock II rims. 17 225 with michelin pilot xght h4 tires. They balanced them there at the place and since then the same problem i had before came back. Its starts steering to the right. Im not sure what the problem is since its new tires, balanced and 2 weeks ago i had an alligment. Now please who ever responds also please tell me if i dont do anything and leave it the way it is and stop being picky will i have any problems? Thank you all
 

·
Registered
Joined
·
0 Posts
Discussion Starter #3
I would start with:<br> <br> 1. checking pressure in all 4;<br> 2. re-torquing all lug bolts exactly to the specs using a good torque wrench.<br> <br> if above doesn't help, try to swap fronts with rears and see if the behavior persists. If it does, it likely needs to be realigned again, you might want to try some reputable independent shop. My experience with dealers tells me that they are not to be trusted at 100% as far as alignment is concerned.<br> <br> Also, remember, H-rated tires are manufactured with less precision than Z- or even V-rated ones. Maybe yours is the case :(<br>
 
1 - 4 of 4 Posts
Top