Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My aux fans, the two fans infront of the radiotor, won't stop.
I notice the problem today after lunch.
I came home from lunch, went in the house for about an hour, came back to the car and the fans still running. I drove around for a while, turn off the car and the fans still on. I drove home, turn off the car and waited for a long while and they won't turn off. I pulled the relay for now, any help would be greatly appreciated.
2002 ML320
 

·
Outstanding Contributor Always Remembered RI
Joined
·
52,804 Posts
Disconnect the temperature sensor and see if the fans stop
 

·
Premium Member
Joined
·
16,759 Posts
Probably the relay is stuck in the activated position. Take a similar looking relay and put it in place of the fan relay. If you still have the same problem, I'll tell you what to check for.
 

·
Premium Member
Joined
·
6,456 Posts
A very similar thing happened to me several years ago with my 01 E430, soon after I had just washed her. Called up roadside and they suspected some water had gotten into one of the connectors, allowing a relay to stay activated. They asked me to disconnect and reconnect the fan harness (the connector for the E's fan was right in front of the radiator towards the driver's side). That solved my problem. I don't have access to my ML now but you may want to look in the general area. BTW, do this with engine NOT running please!!!!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Thanks for all the help.
First update:
I put the relay back in and the problem start again after a ten minutes drive with the AC on. I opened up the hood and hit the relay with a screwdriver and the fans stop. I'll see if I can get a new relay Monday and see. The connector is next if it's not the relay.
 

·
Registered
Joined
·
3 Posts
Hi,
MBZ dealer in Calabasas, CA who did very poor job on my ML320 and within 3 weeks caused me to be stranded on 405 freeway for 4 hours and eventually towed to nearest MBZ dealer who upon inspecting for $275. recommended following work (by the way this was just 3 weeks after I took the car to Calabasas MBZ dealer):
P/S PUMP (LEAKING FLUID), L/SIDE VALVE COVER GASKET (LEAKING OIL), BOTH VACCUM HOSESE AT INTAKE, WINDOW SWITCH PACK AND STEAM CLEAN MOTOR. The cost was over $2100 plus taxes. I realized that these dealers are charging hands and legs for small jobs. I need the experts to tell me where should I take my car so that I won't go bankrupt by fixing my car with dealer(s).
Thank you,
Mike
 
1 - 7 of 7 Posts
Top