Mercedes-Benz Forum banner

Help on light instrument cluster

1048 Views 3 Replies 1 Participant Last post by  Guest (MBNZ)
Need some help I have and 1984 190e the lights on the instrument cluster and all the switches are out and the fuses are good it seems that on the instrument cluster are some sort of fiber optic but I don't know were are they coming from any ideas on were are they connected to thanks
1 - 4 of 4 Posts

· Registered
Joined
·
36,559 Posts
Discussion Starter · #2 ·
Hmm, had the SAME propblem in my 190 D (1985). Do you know where the light dimmer is?? I did not and assumed that my car did not have it. Lost lights a couple of times and I thought it's the electrical prob. Well, the dimmer switch is the same push button as your trip odometer- instead of pushing it (resets trip to zero), just turn it. If EVERYTHING is out, it's probably the dimmer. <br> ;-))
 

· Registered
Joined
·
36,559 Posts
Discussion Starter · #3 ·
Check the multi plug on the back of the cluster. It is the 13 or 15 pin plug. I think it is wire #4 or #5 should have power (Sorry I am doing it from memory) One of the wires provides power to the cluster which in tern provides light to the fiber optics. My cluster had a short in the wiring between the dimmer switch and the plug. Had to due some creative wiring around the problem.It kept buring out the wire between the plug and the dimmer switch. Utimately it was a short in the push button unit that caused my problems and it would not burn out the fuse. Your problem could also be a bad instrument dimmer switch.
 

· Registered
Joined
·
36,559 Posts
Discussion Starter · #4 ·
Thanks today I was trying to find out what it was and then touch one wire behind the cluster and they came out must to been lose but did not see which one if the go again I probable have to take the thing out and make sure all the plugs are tight thanks
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top