Mercedes-Benz Forum banner
1 - 14 of 14 Posts

·
Premium Member
ML430
Joined
·
2,662 Posts
Discussion Starter · #1 ·
I just got my car back today. It was "Fixed" from what the guys said that worked on it. His name is David from Advanced Transmission. I check out the car. Seems to be good.
I jump in, get out of their parkin lot. Well. The car shifts fine. But when you press on the gas with alittle pressure to get it to shift down to the next gear it downshifts, revs high, and then jerks really bad into a gear ( i cannot tell if it is lower or higher ) I called and talked to one of their techs. He said it just might be the computer getting use to the car, i beg to differ. But i know nothing about transmissions.
My plea to you guys is, have you ever heard of this? If so how can i take care of it? Or do i need to take it back to this place and get one of them to look at it. I just got the transmission replaced in it. It ran me 1064.20 for the install and removal of the old one. I got the transmission for free due to warranty.

Please help me.
 

·
Member
'00 ML320 Elegance
Joined
·
8,965 Posts
ttaleric - 2/1/2005 4:16 PM
He said it just might be the computer getting use to the car, i beg to differ. But i know nothing about transmissions.
What he said is true. The transmission does require some time to adapt to your driving style. The first little bit will feel rather uncivilised at first, but the only thing that you have to do is to keep driving the ML normally for another day or two.

Good luck
 

·
Premium Member
ML430
Joined
·
2,662 Posts
Discussion Starter · #3 ·
Thanks Drew, seriously hearing that from you makes me feel 10x better. I don’t trust many people with my SUV.. But it just felt un-natural. But I guess it needs some wear time. Does my case sound like that? Just from your understanding?

And Drew, ill be driving to Raleigh from here, about a 4 hour trip, will this be ok? Will it not wear it too fast?
 

·
Premium Member
ML430
Joined
·
2,662 Posts
Discussion Starter · #4 ·
This is a rebuilt transmission. BTW if it makes a difference.
 

·
Member
'00 ML320 Elegance
Joined
·
8,965 Posts
It doesn't...

ttaleric - 2/1/2005 5:17 PM

This is a rebuilt transmission. BTW if it makes a difference.
It doesn't matter if it's a re-built transmission. The transmission control unit needs to re-learn a driving style otherwise it will revert to the baseline factory settings.

When I had my TCM updated to the latest version, the initial day or so was not the smoothest either. In my case, I could help it to shift along when I wanted a little easier since I have Touchshift on my '00 model. In your case, just keep on driving normally [:)]
 

·
Premium Member
ML430
Joined
·
2,662 Posts
Discussion Starter · #6 ·
Ok, so gas it like i normally do, and let it do its thing. And it will learn how i drive.. I have a 1yr unlimited miles on the tranny, so if it shits out again i can get another one. Thanks Drew! Others members feel free to let me know what you think too!
 

·
Registered
98 ML320& 05 ML350SE
Joined
·
147 Posts
ttaleric - 2/1/2005 7:49 PM

.... ill be driving to Raleigh from here, about a 4 hour trip, will this be ok? ....
Watch for the unexpected. When the 5y.o. OEM battery on our 98ML gave up on a long trip, I had it replaced at a MB dealer. They did not tell me that the tranny computer would have to "relearn" and I drove off. Well, 2 hours into the return trip, I went to pass a truck on a 2 lane hwy and... you guessed it, the ML would just NOT accellerate or kick down, problem was a 18 wheeler was headed right at us! That was SCARY to say the least.

Just be a little cautous during the first few days, and drive the ML a little aggressively from time to time, to make sure it relearns your driving style.
 

·
Premium Member
ML430
Joined
·
2,662 Posts
Discussion Starter · #8 ·
Thanks man!!!
 

·
Registered
2014 ML350 BlueTec
Joined
·
2,626 Posts
RE: It doesn't...

Drew - 2/1/2005 8:33 PM

ttaleric - 2/1/2005 5:17 PM

This is a rebuilt transmission. BTW if it makes a difference.
It doesn't matter if it's a re-built transmission. The transmission control unit needs to re-learn a driving style otherwise it will revert to the baseline factory settings.

When I had my TCM updated to the latest version, the initial day or so was not the smoothest either. In my case, I could help it to shift along when I wanted a little easier since I have Touchshift on my '00 model. In your case, just keep on driving normally [:)]
Drew...Would you be able to share with us, what is involved ,in updating the TCM.....[?]
 

·
Member
'00 ML320 Elegance
Joined
·
8,965 Posts
RE: It doesn't...

C-Rod - 2/1/2005 7:20 PM

Drew...Would you be able to share with us, what is involved ,in updating the TCM.....[?]
They just replaced the entire module, from what I understand. I had a couple of harsh upshift/downshift issues and we thought that changing the TCM would help (and it did).
 

·
Premium Member
ML430
Joined
·
2,662 Posts
Discussion Starter · #11 ·
Drew

Do you think i should still call the guy that did it and see what he says?
 

·
Premium Member
ML430
Joined
·
2,662 Posts
Discussion Starter · #12 ·
RE: Help me out.. jangr320

jangr320 - When you went to accelerate, did your RPMs go high, and then out of no where drop back low and jerk you back? I am just trying to figure out what this cuold be, because the guy that did my car is not returning my call.
 

·
Registered
99 ML430
Joined
·
18 Posts
If this helps:

I had a very similar problem with my '99 ML430. I took it to my mechanic and he couldn't find anything wrong on the computer. When he took it to a factory dealership (I live in Stuttgart, Germany) they couldn't find anything wrong on the big computer either. They finally found the problem to be the mass air sensor. It cost a grip to get fixed because they basically just swapped parts till they figured out what was wrong. It cleared up the problem.

And now if I could just figure out what is wrong with it now...
 

·
Registered
98 ML320& 05 ML350SE
Joined
·
147 Posts
RE: Help me out.. jangr320

ttaleric - 2/2/2005 7:44 PM

jangr320 - When you went to accelerate, did your RPMs go high, and then out of no where drop back low and jerk you back? I am just trying to figure out what this cuold be, because the guy that did my car is not returning my call.
Sorry, but I don't recall what the actual sequence of events, as I was more concerned that the 18 wheeler was getting really close and as I was passing another long truck that was slow, I could not brake and fall in behind.

I just remember that "no accelleration" no matter how hard I pressed on the gas pedal and downshift to 4 or even 3 had NO REACTION - it felt like complete gas starvation.

After a day of driving, it returned to normal though.

As for the MAF, I did a swap too - the "check engine" light went on the dealer said MAF was shot, wanted $1000 for re&re. Got a new MAF off eBay for $135 and did it myself. Did not require a dealer "computer reboot" either. Just plug and play and within 10 min, the check engine light went off.

I figured that the CPU in the truck had to have some sort of feedback loop for the MAF.
 
1 - 14 of 14 Posts
Top