Mercedes-Benz Forum banner

1 - 13 of 13 Posts

·
Registered
1999 C230 K
Joined
·
12 Posts
Discussion Starter #1
I took my 99 c230 kompressor back to get repairs after spending close to 2k on a new transmission control module to find that a week later I need a new supercharger and Mass airflow sensor. The repair shop qouted me $4200. It wont get out of second gear and cant go faster then say 35 40 mph...The shop told me the supercharger is leaking oil on the MAF which caused it to go out! What should I do and any ideas on a cheaper fix besides selling it!!!
 

·
Registered
'99 2.3L Kompressor
Joined
·
1,944 Posts
You need to find a competent mechanic. Your current one doesn't know what they are doing and are just throwing parts at your car at your expense.
 

·
Registered
2004 Lexus LS 430 Modern Luxury. 2012 Acura TSX (fun fun) Maybe MB again one day...
Joined
·
2,604 Posts
xvvvz said:
You need to find a competent mechanic. Your current one doesn't know what they are doing and are just throwing parts at your car at your expense.
Times ten!!!
 

·
Registered
2002 ML320
Joined
·
1,951 Posts
Wow... I would be forcing them to replace my TCM with my old working one and credit me the money!! That's ridiculous.

Was this a Mercedes Dealer, or Mercedes Indy Shop? Or was it just a local mechanic that specializes in nothing? I am fearful to take my cars anywhere but the dealer or my Indy Mercedes Shop.
 

·
Registered
1995 C220 102k
Joined
·
588 Posts
This may help... its on ebay right now!!

 

·
Registered
Joined
·
1,675 Posts
Wow big time bullcrap price of $4200! If the MAS sensor is faulty I learned when mine went, that the supercharger doesnt work at its full potential so tell them to MINUS a few grand right there off their quote.
 

·
Registered
1995 C220 102k
Joined
·
588 Posts
yeah, i think id fix it myself..................
 

·
Registered
1999 C230 K
Joined
·
12 Posts
Discussion Starter #8
Thanks to all who responded..It was a major dealership in dallas..Im confident in the work at the dealer but the price is just outrageous!! I had an indy shop mechanic who is certified look at it. He said he can put a new MAF on for 250.00 and thought the problem will be solved....cross my fingers if not i'll be looking for a supercgharger..
 

·
Registered
Joined
·
1 Posts
Just want to find out if the problem was fixed with the replacement of the MAS or was the supercharger is really leaking oil to it. I'm interested to know 'cuz i have a similar problem.
 

·
Registered
1999 C230 K
Joined
·
12 Posts
Discussion Starter #10
The problem was fixed for a few months. Again the MAF covered in oil. I cleaned and reinstalled got a bit better but back to rough idle in Park and while stopped in Drive and neutral no shake at all. I recently replaced plugs and tune up and more power and very smooth at speeds. Stopped at a light in Drive it shakes pretty bad.
Could a clogged fuel filter cause this????
 

·
Registered
1996 C36 ///AMG and a 1995 C280 sport
Joined
·
672 Posts

·
Registered
96' C220
Joined
·
1,275 Posts
MAF or T.B

You could be ruining your MAF's with the oil. Just cleaning them doesn't always get it. Your Throttle Body is probably a total mess if your MAF's are getting oiled, that could also cause that symtom.

Let us know what the final resolve turns out to be.

Good Luck!:thumbsup:

C as in 220
 

·
Registered
'99 2.3L Kompressor
Joined
·
1,944 Posts
You could have a clog in the tubes and valves the recirculate the exhaust gases in your engine. That could then be forcing oily air back into the induction system and then fouling your MAF. Just one more thing to check.
 
1 - 13 of 13 Posts
Top