Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
1988 300SEL
Joined
·
34 Posts
Discussion Starter #1
Ok, noticed this when I was replacing the engine mounts the other day. Looks like something should be covering this hole, but I can't think of what on earth it is. The location is the back of the engine where it connects to the transmission. You can see the flywheel through the hole, and it looks like it's vented below this hole as well.

Any ideas?
 

Attachments

·
Registered
Depends on the day!
Joined
·
13,337 Posts
Yup, plastic cover..not expensive and the dealers will have them:)

if there aren't any close to Albany let me know and I can get one down your way...!

Jonathan
 

·
Registered
1988 300SEL
Joined
·
34 Posts
Discussion Starter #3
Thanks Jonathan! You wouldn't happen to know the specific name or part number for this? There's a benz dealer downtown, so I'll stop by there tomorrow and see if they have it.
 

·
Registered
Depends on the day!
Joined
·
13,337 Posts
it's just a transmission inspection panel, they'll be able to find it in the EPC easy enough:)

If the parts guy is retarded I'll dig up a # tomorrow:)

Jonathan
 

·
Registered
1965 220S, 1999 Volvo V70 (wagon), 2006 Ford Crown Vic Police Interceptor, 72 350SL 4 Speed
Joined
·
1,830 Posts
Man do you ever have a bad oil leak. Your upper front cover may need to be resealed.
 

·
Registered
1988 300SEL
Joined
·
34 Posts
Discussion Starter #6
I haven't checked for any leaks yet, but when I bought it the engine was covered (and I mean cooooovered) in grease. This was just a very messy car. No clue what the PO did to get it in this condition.
 
1 - 6 of 6 Posts
Top