Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
hi to everyone :)

recently got a C270 cdi,it sort of jumped out of gear a few times i think 2nd
when giving it sum welly and just reved freely untill i slowed down to about 5mph then began to drive again.
now today it seems to have got stuck in 2nd gear and wont change at all,
the winter/sumer dont work (stuck in summer).

Also if i flick the gear lever it stays in drive and dont wana change tiptroncly either.

Has anyone ever had this problem before?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #2
Had the conductor plate changed,
fault still persists:crybaby2::crybaby2:

Does the speed sensor come atached to the conductor plate?
 

·
Registered
Joined
·
9 Posts
I have exactly the same problem, same car. I was thinking of changing the connector plate today, but seeing you have done it I'll give it a skip for now. I got a code referring to the throttle position sensor or the likes of that. Ill check it again today and post it a bit later. Are you sure about the P2500 code you are getting??
 

·
Registered
Joined
·
910 Posts
I had the problem of mine jumping out of gear once and reving freely. Then once it wouldn't shift and I had to slam on the breaks to lower the RPM's so I wouldn't blow the engine. Needless to say, shavings were found in the transmission pan and I got a new transmission under warranty.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
done a rescan after resetting all errors,
went for a drive,slipped out of gear again,

scanned and got EGS P220a and P2502
 
1 - 7 of 7 Posts
About this Discussion
6 Replies
4 Participants
andrenas
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top