Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
2001 E430
Joined
·
30 Posts
Discussion Starter #1
Hello guys,

try this one. I changed the CAT last week and recently changed the MAF. all is 1000% better idles great at or around 500 rpms at idle etc etc... I recently noticed a slight rev of engine at start up. it goes to about 1000 then real quickly goes to 1500 the drops fast to 500 and stays there. it drives fine???
I think before i changed the CAT and MAF it reved a liitle at start but not like this with the slight quick jump. Do you think this is bad??? I did not change the O2 sensors nor the fuel filters witch i plan to do..... I quess it could be the O2 sensors????? ANY ADVICE..

thanks
chris
 

·
Premium Member
2001 E320 - Brilliant Silver/Ash: 107,000+
Joined
·
17,193 Posts
You have an E430 and I have a E320 but: when my engine is cold, the RPMs go up to 1200 and pretty quickly drop to 800; that is when I always start driving. Once the engine is up to 80 C then it idles at 500. How was your cold engine behaving at startup before you chaged the CAT and MAF? Yours sounds pretty normal to me.
 

·
Registered
2001 E430
Joined
·
30 Posts
Discussion Starter #3
Same in winter??? with the CAT issue before i changed it the engine was stalling. That is 1000 % better now along with me changed the MAF, The revs i guess are just like yours. I also get a slight hesitation in traffic when i have to stop real quick and then excel caant tell if its ox sensor or fuel filter??
 

·
Premium Member
2001 E320 - Brilliant Silver/Ash: 107,000+
Joined
·
17,193 Posts
No, mine is not quite the same in winter but close to what I told you earlier. It just takes a bit longer to get up to 80 C and that's about as high as the temperature ever gets. In warmer weather it will get to 90 or 100 when I'm driving.

I don't know what's causing your hesitation but if you are patient, one of the experts on here will help you troubleshoot that.
 
1 - 6 of 6 Posts
Top