Mercedes-Benz Forum banner

1 - 13 of 13 Posts

·
Registered
1999 ML 320 130k Miles
Joined
·
20 Posts
Discussion Starter #1
The car starts fine in the morning when cold. If I run around a bit eventually it will turn over but not start. Last night and this morning it stalled on the freeway, after I sat for a while it started again fine. Is this a cps issue or could it be any one of a number of things.
Thanks in advance for any feedback.
 

·
Registered
2002 ML320
Joined
·
357 Posts
Exact same was happening on my dad's 02 ML320 and it was indeed CPS.

Do you have Check Engine Light on? My dad's ML did and once we read it, it clearly said CPS
 

·
Registered
1999 ML 320 130k Miles
Joined
·
20 Posts
Discussion Starter #3
Thanks croat. The check engine light came on yesterday when it stalled on the way home, prior to that it had not been on. However I don't have one of those code reader thingies, I do intend to get one. What is the error code if you know ?
Thanks
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,633 Posts
JO, please click the user CP link and complete your BW profile for vehicle and location as that is often useful information -- particularly when you're asking help and advice. :)

90% of the time the CPS will not throw a code when it fails and in fact that's one of the ways you can tell the issue. Stalling when warmed up, starts and runs fine when cool, no codes? CPS. Of course if you have the code that is further confirmation, but don't be dissuaded by the lack of one.

If you're in the US (there's that pesky profile stuff again) Harbor Freight has a nice little unit on sale for like $50, or there is always ebay. If you're not in the states you'll have to get an interface for the 38 pin connector, no OBD-II outside of NA.

Take care and enjoy the ride,
Greg
 

·
Registered
2002 ML320
Joined
·
357 Posts
Since the light is on the dash, I def suggest you read the code, just to be 100% sure.
Doesn't AutoZone in US read codes for free?
 

·
Premium Member
02 ML320 06 ML500
Joined
·
16,935 Posts
Since the light is on the dash, I def suggest you read the code, just to be 100% sure.
Doesn't AutoZone in US read codes for free?
croat, you too should update your profile with year model and location. Why does everyone not include this information?
 

·
Registered
1996 C220 & 2000 ML430 & 1997 E320
Joined
·
145 Posts
my truck once wouldn't start randomly from time to time. all it would do is wouldn't turn over.. was very annoying..had the crank sensor replaced and hasn't had that problem since
 

·
Registered
1990 190E 2.6,.... 1998 ML320, 2005 ML500SE
Joined
·
3,094 Posts
Same symptoms on my98ML. It was the CPS.
My understanding is that a failing CPS will set an ODB pending code but will not initially turn on the CEL.
Mike
 

·
Registered
1973 450 SL AMG, 1999 ml320
Joined
·
211 Posts
Driver side back of the block and it is easer to take off the driver side front tire and remove the inner fender and you will need a set of reverse torcks to get the one bolt off.
 

·
Registered
Joined
·
3 Posts
Since the light is on the dash, I def suggest you read the code, just to be 100% sure.
Doesn't AutoZone in US read codes for free?

AutoZone or atleast the one I went has stop the service of lending the OBD2 readers.
 
1 - 13 of 13 Posts
Top