Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1995 C280
Joined
·
1 Posts
Discussion Starter #1
Hi Everyone,
I recently purchased a C280 that has been kept up in pretty good condition. However, the turning indicator has begun to stop working. It will occasionally work, but sometimes, as I turn the wheel, it will begin make double clicks and then stop completely for the remainder of the trip. In addition, the emergency flasher ceases to function along with the turning indicator. I tried turning on and off the car, but that does not seem to work. Since my emergency flasher switch was broken, I replaced that successfully. However, the problem remained. As the first setting for the windshield does not work, I thought that my problem may be attributed to a bad combination switch. After spending 3+ hours today replacing the combination switch, I am displeased to find that my problem persists. The weird thing is that the high beam settings and the rest of the windshield wiper settings have worked all along. Any suggestions would be much appreciated. Thanks.
Erik
 

·
Registered
w202 1997 C230 Kompressor
Joined
·
60 Posts
3 months ago, my wiper was on whenever she wants. I changed the combo relay and it is still the same. I read a forum and I just follow it, I put 3 – 4 pieces of Kleenex folded in the same size of the relay, put it on the top then close the housing with the 4 screws. Well, the wiper is only out of control may be once every week, a big improvement isn’t it ! I think there are problems with the wires or connection problems underneath the socket for the combo relay ! I have no choice but live with it now, really not that bad at all !

By the way, I don't think the high beam settings is related to the combo relay !?

You may want to try this if you want !
 

·
Registered
w202 1997 C230 Kompressor
Joined
·
60 Posts
Hi Erik, did you solved your problem yet ?? If not try this – Take the Combo Relay out again, use something like a carpet needle to close the socket connectors a touch and then put the Relay back to the socket !

That works for my car as I think the socket connections became bigger and bigger with all the bumps and roads for years. Hope that this solution works for your car too ! Give it a go if you like !
 
1 - 3 of 3 Posts
Top