Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
05 w463 G55, 2008 w251 R500
Joined
·
54 Posts
Discussion Starter #1
Well, after reading the forums here I decided to get a pioneer unit installed. On my 2005 g55, my installer does not know what wire to tap into to get the steering wheel buttons to work with the radio.

He said it is easy on a 2006+ model because the can bus wires are easily identifiable. I thought the 2006 was the same as 2005, but he swears it isn't. we called axcess in Florida, but they don't have any notes on the G class.

So anyone that has a 2005 or older car and used the axcess steering wheel controller, what wires did you tap?

Thanks in advance!
 

·
Registered
G500, Unimog 2450, Pinzgauer 712M
Joined
·
615 Posts
I have that same Axcess system, also working with a Pioneer. You can connect it to the steering wheel canbus at connector C2 (that was plugged into the Comand). Pins 8 and 9.
There is whole thread about this setup on the interwebs. If you google for my username and pioneer avic you will get it. Can't post the link on this forum.
Your installer might be correct about the 2006 models. Did the steering wheel control buttons work with your old Comand? If yes, you are probably OK, the wires will be where I said. I think there was a model year when the Comand had been upgraded from D2B to a newer system, but the steering wheel didn't get upgraded. The buttons on the steering wheel didn't work that year. If that applies to you, the wires will still be there, but you might have to hunt for them. I can point you where to look if necessary. Try looking on C2 first.
 

·
Registered
05 w463 G55, 2008 w251 R500
Joined
·
54 Posts
Discussion Starter #3 (Edited)
thanks. I think I figured it out. I knew that once I took my radio off, I would have no way to control the clock (since it was set in the command). So I messed around with star and disconnected the command from the loop. when I did that, I was able to set the clock with the steering wheel controls. BUT what that did was also make me lose the volume control from the steering wheel.

I didn't think much of it, since I was putting in the pioneer 120. When I did that, my installer found the brown and red wire, but he didn't find a signal on those wires. That is when I posted here.

I know there is the standard brown and brown/red can bus wire through out the car.

So my next question is- for those that have successfully programmed the axxess steering wheel control with their aftermarket head unit, did you remove command from the loop? are you able to adjust your clock from the steering wheel controls?

still somewhat confused. I am sure I'll figure it out with trial and error when there is daylight tomorrow.
 

·
Registered
G500, Unimog 2450, Pinzgauer 712M
Joined
·
615 Posts
On my 2002, when I used the STAR to eliminate the Comand, it enabled the clock menu on the instrument cluster. There is a menu option to set "No Audio System" or something like that. Sounds like you found the same thing? My volume controls continued to work ie sending signals on the CAN bus, which are then used by the Axcess box to control the volume on the Pioneer.
There are lots of those brown/red canbus wires, but some of them are on separate circuits from the steering wheel. Not everything is on the same bus. Are you sure you have the right one?
 

·
Registered
05 w463 G55, 2008 w251 R500
Joined
·
54 Posts
Discussion Starter #5
On my 2002, when I used the STAR to eliminate the Comand, it enabled the clock menu on the instrument cluster. There is a menu option to set "No Audio System" or something like that. Sounds like you found the same thing? My volume controls continued to work ie sending signals on the CAN bus, which are then used by the Axcess box to control the volume on the Pioneer.
There are lots of those brown/red canbus wires, but some of them are on separate circuits from the steering wheel. Not everything is on the same bus. Are you sure you have the right one?
When I removed command with STAR, I lost the steering wheel volume controls. Not sure why I lost volume control while you kept your volume control????

The pioneer unit is already in, so I'll just poke my light until I find the right wire. Something I found interesting was that I found a twisted brown and red wire that I assumed was the steering wheel control, but it did not have any data signal. where I was confused is that it did have a different color from the other can bus wires through out the car. The can bus wires through out the car are a twisted pair of brown and a brown with red stripe. The twisted pair I found behind the radio was a brown wire twisted with a red wire.
 

·
Registered
05 w463 G55, 2008 w251 R500
Joined
·
54 Posts
Discussion Starter #6
ok, found the wires. the funny thing is that these wires look different from the rest of the canbus wires through out the car. thanks everyone for the help. The axxess controller works fine.
 
1 - 6 of 6 Posts
Top