Mercedes-Benz Forum banner

1 - 20 of 41 Posts

·
Registered
S280 ,another s280,turbo 500 SEL bountyhunter beachbuggy,59 ford pop,vito
Joined
·
236 Posts
Discussion Starter #1
Was on my way home from work 6am this morning and bimbling along about 30/40mph when it was as if my car had jumped out of gear or lost drive
Got out the car to see if i had snapped another driveshaft or something and could see nothing wrong and when i tried the car in drive it set off so thought it was just karma paying me back for something and was now okay but discovered the car will not do more than 20ish mph and is stuck in first gear
Car does everything else normally except just won't change up out of first gear
Is it in limp mode ?
Am unable to read the codes to see if that helps as all my stuff is 30 miles away :(
Anyone got any ideas what could be wrong ?
 

·
Registered
E350CDI, SL600, 500SE LPG, 500SL-32, SL500, Range Rover V8 LPG, Land Rover S2
Joined
·
600 Posts
Ouch. I take it that you've done the obvious thing of checking the fluid and level in the gearbox? Also did you disconned at re-connect the battery just in case something's had an electronic glitch?
 

·
Registered
S280 ,another s280,turbo 500 SEL bountyhunter beachbuggy,59 ford pop,vito
Joined
·
236 Posts
Discussion Starter #3
Yes checked oil level and its okay and oil tight (no leaks from casing)
Will go and disconnect the battery now and leave it disconnected for a bit whilst i have a cup of tea
Am thinking it could be shift solenoid or something like that (something cheap to fix i hope )
 

·
Registered
S280 ,another s280,turbo 500 SEL bountyhunter beachbuggy,59 ford pop,vito
Joined
·
236 Posts
Discussion Starter #4
Well i've disconnected the battery etc and it made no difference
Ran the shift lever through all the positions a couple of times and checked the fluid all with the engine running and the level was maybe half a litre below the marks on the dipstick ,topped it up and it made no difference
Can anybody point me in the direction of any previous threads on the subject as a search didnt pull up anything too usefull
Cheers Ian
 

·
Registered
S280 ,another s280,turbo 500 SEL bountyhunter beachbuggy,59 ford pop,vito
Joined
·
236 Posts
Discussion Starter #5
Until i (we) figure out what has gone wrong with the s class i shall be running around in this

It has no fancy electric gearbox rubbish to go wrong in fact it has no heater ,no seatbelts ,no electric double glazed windows or any other things to make life more comfortable
You just get in turn the key and it works :D
 

·
Registered
S280 ,another s280,turbo 500 SEL bountyhunter beachbuggy,59 ford pop,vito
Joined
·
236 Posts
Discussion Starter #6
anyone no what code gearbox my car should have fitted ie 103 107 or something like that
Car is a european spec 1995 s 280 with the straight six motor
 

·
Registered
S280 ,another s280,turbo 500 SEL bountyhunter beachbuggy,59 ford pop,vito
Joined
·
236 Posts
Discussion Starter #8
Thankyou very much
At the moment i am at a bit of a standstill as i dont know what is wrong and also can't look on merc wis as i dont know what model code gearbox i have fitted so cant check out any schematics and such like
I have absolutely no idea what could be wrong but am angling towards a stuck solenoid or speed sensor maybe not sending the signal for the box to change up or maybe just a fault code needing reset so if anyone has any ideas at all please help
Cheers Ian
 

·
Registered
S280 ,another s280,turbo 500 SEL bountyhunter beachbuggy,59 ford pop,vito
Joined
·
236 Posts
Discussion Starter #9
Well after spending all afternoon going through the forum reading about gearbox problems i guess i have a duff conductor plate :(
Now i just need to confirm that my transmission (gearbox) is a 722.6 so i can get the new part
Are they ever going to sort that russian vin no website :mad:
 

·
Registered
nothing broken. finally!
Joined
·
2,619 Posts
You are in 2nd gear limp (it's not 1st, though it feels like it)

That's fine, nothing to worry about. Get the tcu read/reset and see what happens.

The one thing to worry about is the car jumping out of gear into neutral. Never good. Conductor plate won't cause that. busted VB would though
 

·
Registered
S280 ,another s280,turbo 500 SEL bountyhunter beachbuggy,59 ford pop,vito
Joined
·
236 Posts
Discussion Starter #13
Mine has P R N D 3 2 and has E and S not w s so i guess i have the earlier box whatever that is
 

·
Registered
S280 ,another s280,turbo 500 SEL bountyhunter beachbuggy,59 ford pop,vito
Joined
·
236 Posts
Discussion Starter #14
You are in 2nd gear limp (it's not 1st, though it feels like it)

That's fine, nothing to worry about. Get the tcu read/reset and see what happens.

The one thing to worry about is the car jumping out of gear into neutral. Never good. Conductor plate won't cause that. busted VB would though
How low is first gear then if i can only do 30 in second ?
Don't think the car jumped out of gear it was just the best way i could think of too describe it ie if you were driving a manual (stickshift ?) and it jumped out of gear thats what it felt like because the revs went up and down when i hit the throttle but the speed didnt alter at all
Be a couple of days before i can read the codes and reset stuff due to work commitments but even then i am fairly convinced my car has all the symptoms of a knackered speed control in the electric plate
Just need to know which box i have and if the same box is fitted to any other models in the Benz range
 

·
Registered
nothing broken. finally!
Joined
·
2,619 Posts
40 in second will put you at like 5k.. yeah i know watch it closely, it does shift 1-2 more than likely but anything is possible. regardless you are in mechanical only shifting mode


I see what you mean, you could have been put in 3/4th gear limp. that would somewhat feel like you are in neutral, especially if you didn't hold the gas down long enough to get it to move.

you have the 722.604

just keep in mind that you have a hard code so even if you correct the cause, you need to clear it to get it unstuck.

gl
 

·
Registered
S280 ,another s280,turbo 500 SEL bountyhunter beachbuggy,59 ford pop,vito
Joined
·
236 Posts
Discussion Starter #16
Thanks for the info gyrate (and others)
Now has anyone got any idea which other models have the 722.6 box so i can get one from the scrapyard as i may as well replace the whole box as mine has 254000 miles on it
 

·
Registered
1997 S500V, 1999 S500 grand edition, 2006 s65 amg
Joined
·
7,356 Posts
man these 722.6 transmission are garbage from my experiences. they have so many glitches its not even funny. i had two older s class and they had the 722.5 and those ones were great except the reverse messes up on those. mercedes+transmission=fail lol

but IMO its better to have yours rebuild-ed rather than a used one since you cant tell if the tranny is bad by looking at. unless the scrap yard offers a warranty. but if you have it rebuild make sure they get oem gaskets since the chinese knock offs tear easy
 

·
Registered
1997 S500V, 1999 S500 grand edition, 2006 s65 amg
Joined
·
7,356 Posts
i had mine done for about $1500 with all new electronics. but i had to find a tranny oil pan since mine had a huge dent and was leaking
 

·
Registered
nothing broken. finally!
Joined
·
2,619 Posts
Thanks for the info gyrate (and others)
Now has anyone got any idea which other models have the 722.6 box so i can get one from the scrapyard as i may as well replace the whole box as mine has 254000 miles on it
w210 e class
w220 v12
c class from 1996? certainly 1998+ have them up until the 7g models
r129 1996+

also some chrysler vehicles but i wouldn't go there

basically most mercedes models from late 90s until mid 2000s use some variant of it. but stick to 140/210/129 for assured compatability

254! you've done good. pretty much a record! that's in miles right, not km?

man these 722.6 transmission are garbage from my experiences. they have so many glitches its not even funny. i had two older s class and they had the 722.5 and those ones were great except the reverse messes up on those. mercedes+transmission=fail lol

but IMO its better to have yours rebuild-ed rather than a used one since you cant tell if the tranny is bad by looking at. unless the scrap yard offers a warranty. but if you have it rebuild make sure they get oem gaskets since the chinese knock offs tear easy
if you rebuild get it done at a specialist shop where they can upgrade the box so you don't have to worry about mechanicals failing ever again. if you aren't keeping the car forever or racing it or something, it doesn't matter. but if you want it done right, it's an awesome box to mod! i guess... $$$$
 

·
Registered
S280 ,another s280,turbo 500 SEL bountyhunter beachbuggy,59 ford pop,vito
Joined
·
236 Posts
Discussion Starter #20
Would love to be able to get the transmission rebuilt but to be honest i think i will take a chance on one from the salvage yard as it will cost me £100 ($150) as opposed to £1000 + ($1500 ?)
Might even go to the stealship and price up the electric plate stuff and just swap that over for now + they should be able to confirm what box i have fitted as the way my luck has been going lately i will end up ordering the wrong bits
 
1 - 20 of 41 Posts
Top