Mercedes-Benz Forum banner
1 - 2 of 2 Posts

· Registered
2000 SL600
5 Posts
Discussion Starter · #1 ·
Please R107 gods and goddesses, I need help.

Working on a friend's '72 350SL that started up after 8 years of storage...and then gradually lost spark while in my garage (while replacing brakes so not associated.) I took the Benzworld suggestion and ordered and installed a Pertronix 1885. Tried first with the switchgear and nothing. (Well, actually I saw a random very tiny low voltage jump from the tower of the coil once when I tried to test a small jump from the tower to the wire.) Then tried bypassing the switchgear using the directions. I now have Pertronix black to coil negative, and red to positive and positive to the hot side of the .4ohm resistor. I have a wire running from the screw on the body of the dizzy to the battery ground. Nothing - no spark jumping even jumping from the coil tower. I've tried the stock coil, a Bosch red coil I have and a Flamethrower I grabbed out of another car. There is power to the coil at the + with the ignition on .

Any ideas? I'm guessing I just have a DOA Pertronix.

· Premium Member
'72 350SL, '85 300D, '98 E320, '19 Subaru Outback (sold '14 GLK250)
14,152 Posts
Wiring sounds to be same as diagrams posted in EGV107.

Only suggestions:
- Make sure magnets are all the way down and aligned with pick up coil as in this pic.
- Double check that power is coming from ignition switch side of 0.4ohm resistor and that you are getting 12v while cranking. Maybe run a wire from battery. Don't leave it connected - just touch it while cranking, otherwise chance of burning out the 1885. Same can happen if ignition switch left on while trying to trouble shoot.
- Maybe call Pertronix and ask if they have suggestions for testing the Pertronix before you return it?
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.