Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
1986 190e 2.3 8v
Joined
·
154 Posts
Discussion Starter #1 (Edited)
Hello my name is AX, and i recently got my first MB not long ago, it is a '86 190E 2.3...
I really like the car, and i would like to bring it back to glory. Hoipefully with your help. I'm pretty good around a car, but this one is a lil different from the chevys that i've been stuck on...
anywho......... glad to be here and let the games begin!!!!!

:sawzall:
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts

·
Registered
1986 190e 2.3 8v
Joined
·
154 Posts
Discussion Starter #3
TY Eric, As i scour through the posts trying to find fixes to my issues......i believe i found one.....motor mounts....my car all the sudden has been shaking/shuddering something aweful on acceleration. i'm now recalling a bang coming from under my center console area..........i was like WTF was that!...(motor mount pieces flying?)....that was prob when the bad vibes/shuddering got real bad. i will check it in the AM as it is pretty late now.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
More likely the propshaft rubber couplings.
 

·
Registered
1986 190e 2.3 8v
Joined
·
154 Posts
Discussion Starter #5
where do i find these? i mean on the car? are they in the driveline?
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Flexi disc is at the end of the transmission and the front of the prop;
Flexi disc kit A108 410 01 15

Or the center propshaft rubber mounting in the center of the two piece prop shaft A111 413 00 12

You will understand better when you can get under the car.
 

·
Registered
1986 190e 2.3 8v
Joined
·
154 Posts
Discussion Starter #7
kewl thanx, i'm flippin through my haynes manual and i gotta say its the worst haynes manual i ever had!!! i have an idea whats up....makes sense and i will definately check it in the AM.

okay , if i may........since i believe i'm talkin to the right guy.......my car has a "chirping" ...to me it makes my car sound like a VW bug. is this normal? or how can i fix that?

This 190 is my first benz and i got it for next to nothing, to save $ on gas. Turns out this car is stealing my heart. It is a very fun car and i really appreciate the way it drives even being 24 yrs old and tired.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
The chirping sound is most likely a belt or one of the pullies but I am guessing as we do not have any 190 in this country so I must fall back on technical experience for which I have a lot lol.
 

·
Registered
1986 190e 2.3 8v
Joined
·
154 Posts
Discussion Starter #9
just read another post.....said chirping waiting at the light----->YES, then put it in neutral it stops------;--->YES....prob motor mounts.
but the vibrtion really to me sounds/feels like these flex discs.

JOY......... MY RUBBER IS MUSHY!

okay so now i ask you this, do you know where can i find polyurethane to replace this rubber?
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Sorry I would not know where to buy as I am in China and we only use OEM parts.
 

·
Registered
1986 190e 2.3 8v
Joined
·
154 Posts
Discussion Starter #11
you are absolutely right. front flexdisc fried, i ordered parts online, they should be here tommorow. I willl get them in this weekend. The motor mounts look tired also. will get to those next.....
TY Eric.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Thanks for the up date and with new engine mounts you will feel the difference.
 
1 - 12 of 12 Posts
Top