Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
1983 300 TD Wagon
Joined
·
5 Posts
Discussion Starter #1
Am now the proud owner of a 1983 300td Wagon, love it . Got it off the daughter of the original owner last summer for $700.00 with 216000 on the clock. Fixed the rear hydraulic suspension with a new pressure hose . That got it back up but have to put new accumulators on it is a bit hard. Spare was never on the ground till I ran over something . Put new glow plugs in 2 weeks ago that cured the no start in a hurry. small rust decent paint and interior. has the usual quirks but will sort them out . Hope to try it on WVO soon . Thanx for having me and keep on Dieseling!
 

·
Registered
1983 300 D turbo
Joined
·
303 Posts
Welcome and congrat's on the new wheels [:D]. The one thing we LOVE here is pictures, so when you get a chance, post and post often.
Happy Motoring
Lancer
 

·
Registered
1983 300 TD Wagon
Joined
·
5 Posts
Discussion Starter #3
Will take some pics soon have to clean her up with the salt spray and the fuel all over from breaking the rear return line when I did the glow plugs , not going to play with those 22 yo lines going to the stealer-dealer tommorrow. Thanx
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Hello and welcome! [:p]

Make yourself at home. If you need information there is an Online Tech Thread pinned in this W123 forum. May it serve your needs well [:)]

Drive safely! Enjoy your new love!
 

·
Registered
1991 300 SE
Joined
·
18,534 Posts
Welcome – looking forward to pics.[:)]

Just '300 TD' – ‘wagon’ is redundant.
 
1 - 5 of 5 Posts
Top