Mercedes-Benz Forum banner

Heater not working :-(

1941 5
Has anyone had this problem before?
Winter is coming and my heater stopped working about 2 weeks ago. I havent had a chance to look at the car properly yet, but any advice is welcome (other than telling me to wrap up warm [:D])
1 - 6 of 6 Posts

· Registered
00 S500,99 4wgn,87TD
Joined
·
577 Posts
Has anyone had this problem before?
Winter is coming and my heater stopped working about 2 weeks ago. I havent had a chance to look at the car properly yet, but any advice is welcome (other than telling me to wrap up warm [:D])
first thing to go on the 140 is usually the blower control module.don't forget to check ALL fuses.
 

· Registered
W140 S class, E31 850Ci, XC90 Exec AWD geartronic
Joined
·
444 Posts
Discussion Starter · #4 ·
Thank you Barry and Benzdoc for your advice

Thank you Barry and Benzdoc for your advice
I have checked the fuses, all is well. The blower still blows, I can redirect the air but seems supply cold regardless of what temperature I select.

I shall flush the cooling system and try running the diagnosic mode as soon as I have some time. I recall that earlier benz's suffered from a sticking monovalve in the firewall for which bosch supplied an overhaul kit. I am not sure If 140's have such a system. I'll have to investigate further. Thanks Barry for the valuable link - I owe you one buddy [;)]

Gill:
Frank posted this info in july.

http://pages.prodigy.net/jforgione/MB_AAC.html

Barry
 

· Registered
Joined
·
2 Posts
Re: Re: Heater not working :-(

first thing to go on the 140 is usually the blower control module.don't forget to check ALL fuses.
Where is the blower control module located (behind
the climate control buttons/display in the dash)?

My blower sometimes cuts out, but only when the
A/C is on. Makes me wonder if I've got a blower
control module issue (temp sensitive).

P.S. Thanks to the person who posted the URL for the
climate control diagnostics.

rjcmstar
1993 W140.032
 

· Registered
2001 S500
Joined
·
44 Posts
Blower motor and regulator are located under the hood (passenger side) behind the engine (...

Blower motor and regulator are located under the hood (passenger side) behind the engine (near the windshield). It is under the plastic compartment that houses the charcoal filter (if you have one)and I think the winshield wiper motor. Thankfully, it is under the hood and relatively easy to get to as opposed to being in the dash, a la evaporator.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top