Mercedes-Benz Forum banner
1 - 11 of 11 Posts

·
Registered
01 ML55,93 500SEL
Joined
·
160 Posts
Discussion Starter · #1 ·
Im about to buy HD tuner( Pioneer GEX-P10HD ) for my pioneer f90bt. My question is, do I need a 2male 1female adaptor or 2female 1male? many thanks
 

·
Registered
2003 ML500 & E320
Joined
·
158 Posts
(1) FEMALE in, and (2) MALE out

Will
 

Attachments

·
Registered
2003 ML500 & E320
Joined
·
158 Posts
I have found that the reception on the HD module is not what I would like. The F900BT has a POWER ANTENNA connection which is to power the amp in the ML antenna.

Let me know what your findings are.

Will
 

·
Registered
2005 E320 CDI, 2016 E250
Joined
·
3,199 Posts
j3cubcapt...have you gotten rid of the annoying static when turning the rear defrost on? I have that issue and I know there is a fix - possibly the reception is being muddied by that issue (if you have it).
 

·
Registered
01 ML55,93 500SEL
Joined
·
160 Posts
Discussion Starter · #5 · (Edited)
Thanks Will, I didnt know that the f900bt have that direct connection. In essence, the f900bt dont need the atenna adpater?Just purchase the f90bt. Is there any way for me to get my subs to work? I dont care bout the cd changer. So this is the list I have purchase before my installation for the f90bt, let me know if im missing something. thank you all
1. antenna adaptor
2.metra 70-1784 (harness)
3.installation kit AVT-VA133
4.PIONEER GEX-P10HD HD RADIO TUNER
5.2male 1female connector
6. back up camera
 

·
Registered
2005 E320 CDI, 2016 E250
Joined
·
3,199 Posts
What specifically do you mean by "Is there any way for me to get my subs to work?" Are you talking aftermarket AMP and Subs or the Bose unit installed in most vehicles? If they are aftermarket...buy the IEC AULOC and tap your lines...use that to connect an RCA wire to the AMP and run power lines...the rest should be simple.
 

·
Registered
2003 ML500 & E320
Joined
·
158 Posts
j3cubcapt...have you gotten rid of the annoying static when turning the rear defrost on? I have that issue and I know there is a fix - possibly the reception is being muddied by that issue (if you have it).
Well, I have to admit I have not had that problem. Lucky I guess. I live in Texas and we don't really have cold weather, however I have indeed used the read defrost over the last few months with no noticeable static.

Will
 

·
Registered
2003 ML500 & E320
Joined
·
158 Posts
In essence, the f900bt dont need the atenna adpater?Just purchase the f90bt.
The F90BT will require the same antenna adapter as the F900BT. The only real difference between the two are the output voltage, and the warranty.

What Backup camera are you thinking about using and where do you plan to attach it? License plate or bumper?

Will
 

·
Registered
01 ML55,93 500SEL
Joined
·
160 Posts
Discussion Starter · #10 ·
hey will, I plan to put the backup cam on the plate. Really debating on that as well. Dont know if I should go with the more expensive ccd or the cheaper cmos. Do you think 180 angle is bit too wide. I dont really want it to look like a fish eye view. Do you have a backup and hd tuner installed?
 

·
Registered
2005 E320 CDI, 2016 E250
Joined
·
3,199 Posts
OK W163, just wanted to clarify :)

I'm also interested in a back up camera - would love to see install pics and details of everything if possible.
 
1 - 11 of 11 Posts
Top