Mercedes-Benz Forum banner

1 - 20 of 40 Posts

·
Registered
2004 S500
Joined
·
115 Posts
Discussion Starter #1
Are there any stories of how you took a 15 hour road trip and your S-class was fine? No overheating? I'd LOVE to hear some happy stories about driving these. While I know this section is for repairs/info/DIY, etc...there is no section for how great these cars can be.

Anyone want to share a story? Here's mine:

I had a 2003 S600 with 40k miles on it and I drove it over 10,000 miles around the country with no problems. Had it looked at by dealer afterwards and he said all is fine (no leaks, cracks, etc..). I also had a 1999 SL500 with 50k (drove it till 70k miles) and all I replaced (not by choice) was water a pump.
 

·
Registered
Joined
·
918 Posts
We used to have a 97 S420 and would routinely drive 24 hours strait to Michigan, and then back again. Also drove it to Las Vegas one time. Never had a single problem on any of the trips. Sold it with almost 250,000 miles.

Before that my father had a 95 S420 which he bought with 40,000 miles and drove for another 200,000. That one was not as reliable and stranded us twice, once in Chicago and once in Toronto. It also had wiring harness issues.
 

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
Yes, last year I drove the length of New Zealand from Dunedin to Auckland over two days. Including the ferry between the islands. It must have been about 25 hours of driving all up.

That's about the 3rd time I've done the trip in my W140 and it's been good every time.
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,639 Posts
Can't even buy a problem on a 95 S320. It's ridiculous. I may have to start having someone sabotage it so I can have something to fiddle with.
LoL,Same here with the 93/S500 , I may have to purchase some Warranty to make sure that at least something gets me busy fixing ,i'm sick and tired of doing Oil changes & Sparkplugs just for the Fun of doing it .
My Car is starting to get exited as she is going on her usual Christmas long Highway Trip .
After a good 10 Hour Drive she dosnt seam wanting to Stop , when i drive i dont stop,it's only Petrol and go ,on arival to Destination 10 Hours later the Cars Emotions or Feel is the same as if we just wend for a drive around the Block ,awesome Engine these 500's ,the more you drive the more she feels good, i wonder how a 600 would feel(?).
Ciao :thumbsup:
 

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
Did you do all that in your 1993 300SEL?
Yes, this has been my only car for the last 5 years or so now. I also did about 4-5 8 hour rounds trips a year between Dunedin and Christchurch in the South Island. Now it's not so regular 4 hour round trips because I've moved.

Funny, seems the car only breaks when it's not having long trips lol, my car has been fairly reliable - seems to be all the extra or comfort features which fail, not so much the drive train (touch wood).

Although I had to replace the gearbox...
 

·
Premium Member
1999 S600 Sedan, 1999 S600 w/ 4-pl seating, 1995 S600 Coupe, 2-1992 600SEL's, 2002 ML55, 1998 SL600
Joined
·
2,423 Posts
Unfortunately, I'm a tad too fussy NOT to find something wrong with the cars, and my wife is trying to reign me in.

But then again, my cars are ready for show just about anytime.
 

·
Registered
W220 S320 CDI 2005; W140 S280 1994 (Sold Nov. 2012)
Joined
·
867 Posts
I've had my 1994 S280 for 11 years, all but a month. Bought it at 46k miles and now have 128k on it. It's let me down twice - a water pump at about 85k and right outside my house, and a sudden battery failure in mid-summer (!) after 8 years about a mile from home.

I've toured Scotland in it a couple of times (about 1k miles a time) and the South of France a couple of times (about 3k miles a time) - it never faltered.

Mike
 

·
Registered
1999 S500 GRAND EDITION (32,800 Miles)
Joined
·
269 Posts
Problems--you have no idea

In the past 30K miles and 4 years my car has had the following list of troubles.

1) It demands an oil change every 6000 miles.
2) It demanded spark plugs after only 50,000 miles.
3) It let a rock break a headlight lens.
4) It required a change of windshield wiper inserts.
5) The steering dampener started to make a noise.

That is the entire grusome list of problems that this car has caused.

Telechronos:):):)

1999 S500 Grand Edition
1984 380SL
1955 MG TF1500
1969 Factory Stick, Factory Tri-Power Pontiac Grand Prix SJ
 

·
Registered
'84 300DT, '97 S320
Joined
·
682 Posts
Only operational problem I knew of when I bought our '97 S320 in March 2010, was the head gasket / oil leak, which I promptly had a shop fix. Lots of little broken/worn-out things, most of which I've since fixed. About 2 months later, the first cruise past 1 hour (kind of an unexpected funeral - thought it was another couple of years away) was from Atlanta, GA area, through Memphis, Little Rock to NE Oklahoma - 11 hours, 1 stop for gas - in June. Outside temps reached mid-90'sF and A/C worked great, engine temp around 90C. Made the drive much more bearable being in this smooth-riding beauty. I opened the window a few times just to see how quiet it was inside. There was also a power steering pump fluid leak, but it was minimal for the trip. That also has since been fixed (~$25 for new shaft seal - fun DIY).

Return trip was also great. After 11 hours, I still hated to see it end.
 

·
Registered
1998 S420
Joined
·
294 Posts
Bought my 1997 S420 at 109,000 miles in '09 and have driven her since as a daily driver. Not a single thing has broken yet and 141,000 miles I still get 23.9mpg.

Usual things of oil change/spark plugs/trans oil/rear diff oil//shocks etc I did as preventative maintenance.

I baby it :)
 

·
Premium Member
2002 Black SL500, 2000 Azure blue SL500, 2005 Silver (A209) CLK500
Joined
·
998 Posts
92 500 SEL...original owner, 80K miles...nothing major so far. But then again, had it parked for 8 years without driving it while stationed overseas.
 

·
Registered
1994 Benz S320 SWB / 1986 Porsche 911 Targa / 1998 Benz CL 500
Joined
·
1,290 Posts
In the past 30K miles and 4 years my car has had the following list of troubles.

1) It demands an oil change every 6000 miles.
2) It demanded spark plugs after only 50,000 miles.
3) It let a rock break a headlight lens.
4) It required a change of windshield wiper inserts.
5) The steering dampener started to make a noise.

That is the entire grusome list of problems that this car has caused.

Telechronos:):):)

1999 S500 Grand Edition
1984 380SL
1955 MG TF1500
1969 Factory Stick, Factory Tri-Power Pontiac Grand Prix SJ
Some "Gruesome List" Indeed LOL
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,639 Posts
I NEED HELP INSTALLING MY HID'S WITH OUT ANY ERROR MESSAGE
ON THE DASH!!!!!

HELP PLEASE !!

MERCEDES S500 2000
Sry to Disapoint but you need to ask that same Question in the W220 Forum Section since your's is the S500 2000 Model,here it is only for the more serious W140 ,lol.
Also have you done a "SEARCH" as there is a Lot of Info regarding these HID's installations .If it is a W140 & you didnt find anything that Answer's your Question then try creating a New Thread & ask that same Question again .
HID"S are easy to install anyway , should be Plug & Play on most Cars .
Ciao :thumbsup:
------------------------------------------------------------------------------------------------
LoL Walter " I just Noticed that you posted this same Question everywhere on the Forums exept in the W220 ,just go to the W220 Section they will tell you everything there unless they are to busy sorting out the Electrical or Chassis Problems on there Cars ,LoL.
Here is the Link for you & ask there :
http://www.benzworld.org/forums/w220-s-class/
See if you find anything here to solve your Problem .
http://www.benzworld.org/forums/search.php?searchid=6818145
at least you cant say that W140 Owner's are not Helpfull ,we all are where ever we can .
 

·
Registered
1997 Mercedes Benz S320 SWB
Joined
·
274 Posts
Bought my 1997 S420 at 109,000 miles in '09 and have driven her since as a daily driver. Not a single thing has broken yet and 141,000 miles I still get 23.9mpg.

Usual things of oil change/spark plugs/trans oil/rear diff oil//shocks etc I did as preventative maintenance.

I baby it :)
I bought mine with 54,000 miles.

New Michelins, an EGR-valve, two headlight glass bezels (road rocks!), followed all scheduled maintenance, oil changes every 3k miles.

Daily driver. Have driven to Los Angeles and San Francisco (California) from Salt Lake City, Utah twice. Jumped out of my S320 refreshed, little fatigue!

Everything works on my S320.

Now, two years later, and 88,100 miles...still runs well. I anticipate many more years of great service. I'm fortunate to have bought mine from its first owner, who took very nice care of the mechanicals and the paint.


James Combs,
Salt Lake City, Utah USA
1997 S320, 88,100 trouble-free miles
 

·
Registered
1993 W140 500SEL Black/Black, 12014 Ford Fiesta ST Blk/Blk
Joined
·
1,128 Posts
First drive was 21 hours home to NY from MN. It was wonderful.
Car starts every time, runs well in hot or cold. I fixed my AC.
It's been a great car, I never fear long trips in it. It's popular for evening out with friends too, massive back seat, comfy quiet ride and imposing when pulling up to the door of a restaurant to let my guests out there. I've caught people a few times taking pictures of the car too :)
 

·
Registered
1997 S320 LWB Original owner
Joined
·
95 Posts
I'm the original owner of my 97 S320. It's been on 3 NYC to Florida non stops and has spent much of the last year on college tours throughout the Northeast with one unplanned maintenance - a bad water pump.
I will have this car 14 years in March 2011 and it is more reliable now than when I first bought it
 
1 - 20 of 40 Posts
Top