Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
2005 E500
Joined
·
141 Posts
Discussion Starter #1
I had a problem ever since I got my car with the CD changer skipping at least once every time I drove the car (sometimes more). Then, on two occasions, I also got some horrendus noise that I can only describe as "static" when playing CD's. This was using the 6-disc changer with my sound setting on "LOGIC 7". The skipping was not related to physical shocks to the car (like going over potholes etc.) and would even occur when the car was stationary in a parking lot. The "static" when it occured, went away after I turned the car off and then back on again.

The skipping/static occured when listenening to store-bought (as opposed to PC burned) CD's and did not appear to be related to any specific CD or specific slot in the changer. I never placed a "home-made" PC-burned CD in the changer.

I let my dealer know about this, and they went ahead and replaced the CD changer unit when my car was in for a separate issue. I have driven it around for several hours since the replacement of the CD-changer unit and it has not skipped even a single time, even when the car has encountered "bumpy" road conditions.

Based on this, it appears that the CD Changer unit that came with my car was defective. Replacing the defective unit with a new one appears to have completely solved the problems.

I am posting this so that anyone else with a similar problem can get their dealer to fix it for them.
 

·
Registered
W203 modified
Joined
·
2,032 Posts
JG in SB - 2/26/2005 4:17 PM

I had a problem ever since I got my car with the CD changer skipping at least once every time I drove the car (sometimes more). Then, on two occasions, I also got some horrendus noise that I can only describe as "static" when playing CD's. This was using the 6-disc changer with my sound setting on "LOGIC 7". The skipping was not related to physical shocks to the car (like going over potholes etc.) and would even occur when the car was stationary in a parking lot. The "static" when it occured, went away after I turned the car off and then back on again.

The skipping/static occured when listenening to store-bought (as opposed to PC burned) CD's and did not appear to be related to any specific CD or specific slot in the changer. I never placed a "home-made" PC-burned CD in the changer.

I let my dealer know about this, and they went ahead and replaced the CD changer unit when my car was in for a separate issue. I have driven it around for several hours since the replacement of the CD-changer unit and it has not skipped even a single time, even when the car has encountered "bumpy" road conditions.

Based on this, it appears that the CD Changer unit that came with my car was defective. Replacing the defective unit with a new one appears to have completely solved the problems.

I am posting this so that anyone else with a similar problem can get their dealer to fix it for them.
Static is usually an indication of fibre optic damage in the MOST ring. Replacing the CD stacker may have resolved the fault if the fault was within the input and output part of the stacker optical stage.

It may also have been a bad connection to begin with. Swapping units may have improved that situation.
 
1 - 2 of 2 Posts
Top