Mercedes-Benz Forum banner

1 - 20 of 21 Posts

·
Registered
2003 SL500, 2005-E500
Joined
·
52 Posts
Discussion Starter · #1 · (Edited)
harman/kardon® Logic7 not really powerfull

Has anyone notice but me?

I have a 2005 E500 and use to own a 2003 E320 and I must say that I am not happy with the harman/kardon® Logic7® Digital Surround Sound System.

I think it does NOT crank out that much power, punch, i.e. Base! The louder you turn it up, the less rich the sound is.... It's it me or should MB put a better SUB system/SUB amp or amps in general in the car?

I also own a 2003 SL500 and the Bose system is the BOMB!!!!!!!!!

Anyone have any suggestions on adding an inexpensive aftermarket Powered SUB that can be hidden? NOT looking for an SUB that takes up any trunk space.
 

·
Registered
Honda Odyssey Touring 2006 ML350 (GONE) 2006 E350 4MATIC (love it)
Joined
·
570 Posts
broken Links

Your links do not work, and to be honest I found my system to be fine. Depends on what you play the most, but all around it is fine. At home I have a 20k system, so cannot compare, but for a car it is fine, unless you want you go to car audio shows.
I tend to not like it when my Benz sounds like I need spinner rims, but that is only me.
 

·
Registered
2003 SL500, 2005-E500
Joined
·
52 Posts
Discussion Starter · #3 ·
LOL, the Spinner thing was funny....Ya, I don’t want it everyone to hear my music as well, just me but I can say in my 2003 SL500 the sound is far more powerful, I guess because it's a convertible and it needs to be when the top is down. I also own a 2003 BMW 330i with the upgraded harman/kardon, NOT Pro-Logic7 surround, but it also is a more powerful system when you crank it up.... :(

Oh well........thanks for the reply.....
 

·
Registered
Honda Odyssey Touring 2006 ML350 (GONE) 2006 E350 4MATIC (love it)
Joined
·
570 Posts
bsmoove said:
LOL, the Spinner thing was funny....Ya, I don’t want it everyone to hear my music as well, just me but I can say in my 2003 SL500 the sound is far more powerful, I guess because it's a convertible and it needs to be when the top is down. I also own a 2003 BMW 330i with the upgraded harman/kardon, NOT Pro-Logic7 surround, but it also is a more powerful system when you crank it up.... :(

Oh well........thanks for the reply.....
Honestly mine is fine, and tuns up when roof is open or windows are open. Check to make sure you are getting output from the amp. I will agree with this, I had a 2006 ML and that seemed to have a better sound then my 2006 E, with same system... odd
 

·
Registered
2003 SL500, 2005-E500
Joined
·
52 Posts
Discussion Starter · #5 ·
Will do, thanks Endodoc....
 

·
Registered
2005 E500
Joined
·
73 Posts
I would at times like everyone to hear my music and people with spinner wheels would love what I'm playing but this system does lack power. A little boost to the bass would make all types of tunes sound better on this system. I would think you would need to put a separate amp between the AGW and the Sub? Replace the sub also? I've searched for a DIY on this without sucess. If someone could point me in the right direction that would be really appreciated.
 

·
Registered
2003 E500 Sport, 2015 GLA250
Joined
·
94 Posts
My '03 E500 has the Harman Kardon (not sure if it is the Logic 7). I listen to songs from Led Zeppelin and others so you know "now" I like it loud and robust at times.
 

·
Registered
2005 E500
Joined
·
73 Posts
I just fixed the center dash speaker and it sounds so much better. Didn't realize it was kaput until I listened to this one song and I could hear the speaker rattling. All other music just thought the system sounded like crap.

Took it out, glued it back together and now it sounds so much better. I still think the whole system is under underwhelming if you were real hardcore audiophile, but I'm not most of the time and can crank this up and it is distortion free and the bass actually sound much better than pre fix (which is interesting since the center dash speaker is this little tiny 4" thing). So much happier now and thoughts of adding sub are put on back burner for now.
 

·
Registered
'07 E-550 4-Matic
Joined
·
69 Posts
Could you post your source on how you fixed it? My center speaker is pretty bad.

Sent from AutoGuide.com Free App
 

·
Registered
2005 E500
Joined
·
73 Posts
There was another forum where someone mentioned that they glued theirs back together. I don't know where it is, but it is really easy. You need:

1) Good glue (I got a tube of Devcon Home Weld It All Purpose Adhesive at Orchard Supply)
2) Plastic wedge
3) Torx bit set (not sure which one)

You might need:
Soldering iron

Here are the steps:
1) Pry off dash cover with plastic wedge at 11ish and 1ish. Once you're able to get your finger under there, just pull up. Don't be shy, just yank it up. With a good tug, my popped off with a loud noise but no damage.

2) Unscrew two torx screws that hold speaker in and disconnect the cable and remove the speaker

3) Remove speaker cone from metal speaker frame. Be gentle here. I have to describe in words the cone since I don't have any pics. Imagine looking at a cone strait on from the side, small end of cone on bottom and big end on top. Now imagine that that cone has a ring around it near its middle. this cone is the speaker cone. The metal speaker housing/frame is what you glue the speaker cone to (of course after you've carefully removed it from that same frame). Once you remove it, it is pretty self explanatory where you need to glue it down. I glued mine down on the top of the cone and the ring in the middle. At the bottom of the cone is copper wire wrapped around it. No glue there.

The wires are attached to the cone AND to the metal frame. I desoldered the wires from the frame to get the cone off completely. You can try to do without removing wire.

After removing cone completely with wires, I then guped on the glue onto both mating surfaces of the metal frame making sure there was plenty of glue to form a great bond and seal and carefully dropped the cone onto the glue and used my finger to push down the top part of the cone.

Then I let the glue set for about 30 minutes and reinstalled into car. Sounded like crap while glue was drying, worse then before, but in morning when glue was set over hours, sounded like new.

Good luck!
 

·
Registered
2005 E500
Joined
·
73 Posts
Again, it is really easy and if you mess it up, you can get a replacement at the dealer for around 100 bucks or online for around 80ish plus by doing this, I had an excuse to buy a soldering iron.

It took me 30 minutes tops to do this.

Take care!
 

·
Registered
E55 AMG 2004 SILVER ALL OPTIONS + AMG LSD + more mods to come
Joined
·
42 Posts
Logic 7 is pretty poor when it comes to volume, only way is to add a seperate subwoofer.

of you could see if you can source the ultra rare AMG sound system speakers and amp, but i only know one person globally who has one (mbenznl)
 

·
Registered
2006 E320 CDI Obsidian Black
Joined
·
372 Posts
My Logic7 system sounds great. In fact at one time I was looking to upgrade to a better navi and looking at Dynavin because it looked original in styling. When I discovered that it could not be adapted to the fiberoptics I dropped the idea.

I'll keep the the oem navi, as it has always gotten me where I wanted to go, just not as conveniently as others might.

The enjoyment of the HK7 system far outweighs the navi
 

·
Registered
2011 E350 Bluetec, 2005 E320 CDI (sold), 1995 E300 Diesel (RIP)
Joined
·
40 Posts
I love the LOGIC7 in my 05 E320 CDI. I think it is more powerful than my old STS, which had a 425 watt Bose system in it. I also had an 04 330CI with the Harmon Kardon system, and I thought it was weeeeak..it was definitely weak compared to the Harmon in the Benz. My most recent and favorite car, a 95 base model E300, had the standard Becker system in it, so the Harmon in the CDI is light-years better.
 

·
Registered
2004 E320 Wagon & 2004 E320 Sedan
Joined
·
64 Posts
This may sound crazy. For you guys that have the Harmon/Kardon system and are not pleased are you sure it is turned on? There is a selection for the Logic 7 in the command system.

My 211 wagon does not have but the wife’s 211 sedan does. Not a great amount of difference but the HK does seem louder to me.
 

·
Registered
1985 300D California / 2006 E350
Joined
·
64 Posts
..... There is a selection for the Logic 7 in the command system......
Well that's another option I thought I had but do not. I found in the Command manual where to select the HK system, and when I tried to do so on my car, it wasn't there.

I thought for a week that I had leather before I realized it was MB-Tex. At this rate, I'll be driving a Toyota.
 

·
Registered
2006 E320 CDI Obsidian Black
Joined
·
372 Posts
Well that's another option I thought I had but do not. I found in the Command manual where to select the HK system, and when I tried to do so on my car, it wasn't there.

I thought for a week that I had leather before I realized it was MB-Tex. At this rate, I'll be driving a Toyota.
Better take a closer look just to be sure! :eek: :wink_2:
 

·
Registered
2004 E320 Wagon & 2004 E320 Sedan
Joined
·
64 Posts
Well that's another option I thought I had but do not. I found in the Command manual where to select the HK system, and when I tried to do so on my car, it wasn't there.

I thought for a week that I had leather before I realized it was MB-Tex. At this rate, I'll be driving a Toyota.
You may actually have leather seat inserts. My 2004 wagon has the optional leather package and it is obvious. My wife’s 2004 sedan shows leather inserts on the window sticker. Last year on EPC the SA card showed it as imitation/vinyl. Something has changed on the Mercedes side and now the SA card shows it as MB tex-leather. Don’t know about the 2006 models but suspect the same.
 
1 - 20 of 21 Posts
Top