Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
1991 Mercedes 300E 3.0
Joined
·
3 Posts
Discussion Starter #1
Just bought a 1991 300E 3.0 Gave it a tune up, Plugs, wires, air filter, Cap and rotor. very hard to start in the A.M. after sitting all night. After warmed up (1-2 min) it runs fine. Also has a rough Idle. Any feedback would be appreciated.
 

·
Registered
1990 300E 2.6L 144K
Joined
·
59 Posts
Replace the OVP relay. It is located behind a plastic housing behind the battery. I experienced similar problems and replacing that helped my car significantly.

While you are at it, I suggest that you complete your profile so that other members will be able to help you more effectively.

Andrew

Your Parts Search Returned 1 Part(s)
 

·
Registered
2005 E55
Joined
·
785 Posts
Before the OVP.

Premium ethanol free gas. ( shell 91)
Copper plugs
Fuel filter
Air Filter ( if dirty)
 

·
Registered
1991 Mercedes 300E 3.0
Joined
·
3 Posts
Discussion Starter #4
hard start

Thanks for the info. I pulled the fuse on the OVP and was fine. The ABS light came on so. Can the OVP still be bad?
 

·
Registered
1991 300D 116,000m
Joined
·
730 Posts
The OVP fails from the cold solder joints within. I'm not convinced this is your problem, however it's always good to keep a new spare in the trunk.

Since it's only cold starts, I would lean towards the fuel pressure accumulator. I did a simple search and found this. Post 6 is helpful. CBC_ATL always comes through with the links, lol It appears that this fixed the poster's problem. Good Luck.

http://www.benzworld.org/forums/w124-e-ce-d-td-class/1654017-1991-300e-cold-start-issue.html
 
1 - 5 of 5 Posts
Top