Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi-

My 190D engine compartment started making clicking (like pinking) noises a few days ago. Last night it started to shift hard in every gear transition. The brakes are still working fine, but it's taking a little longer for the engine to shut off.

From what I've derived from other posts, it sounds like I may have a bad vacuum pump.

Putting my finger up to each hose coming from the vacuum pump, it feels like it has a fair amount of vacuum on the large hose going to the brake booster and not much vacuum on the small nipple hose which looks like it leads eventually to the transmission modulator.

Q1: Is this possible that part of the pump is broken and I'm only getting vacuum from the larger nipple/hose and not the smaller one?
Q2: With a mityvac, what is the vacuum meant to be coming out of both nipples?
Q3: Is it possible to rebuild the vacuum pump rather that buying a new one?

Thanks.
 

·
Registered
98 SLK230K AMG, 98 E55T, 89 2.5-16
Joined
·
213 Posts
hi,

"...but it's taking a little longer for the engine to shut off." - a friend had this same problem - he'd take out the key and the engine is still running. if this is same problem as yours, then my friend replaced a solenoid that is responsible for shutting down the injection pump. i am only sorry that i cannot tell you the exact location as i am not familiar with the part.

about the transmission shifting hard it could be a vacuum leak on the hose that goes to the modulator. i know that if its disconnected the shifting is really hard.

hope this helps.

regards,
Ray
 

·
Registered
1996 E320, 2005 Toyota Camry
Joined
·
1,810 Posts
190D

My '85 190D was doing the same hard shifting, except that it was from 3rd to 4th, which was almost like a sledge hammer pounding the car. My indie people adjusted the modulator and it was a little better, but still kinda' pounding. Maybe it's a good idea to go ahead and replace the vacuum hose which goes to the transmission??? Or, are there more hoses than that???
Hemersam
 

·
Registered
1977 300D mercedes w123 4 door sedan
Joined
·
65 Posts
Check out Ken Bergsma or Diesel Giant they have kits to rebuild your pump. I rebuilt mine on my 1977 300D Mercedes. Now I have all kinds of vacuum at the brake booster line but none in the smaller lines. Like the one that goes to my shut off valve. It just keeps running to when I turn the switch off. Now I'm really confused.
 
1 - 4 of 4 Posts
Top