Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
553 Posts
Discussion Starter #1
Funny thing happened the other day. drove the car 60 miles then shut it ff for about 2 days. started it up and drove back the same 60 miles,...no problems what so ever. i get into town and go to apply the brakes before a stop sign and i get a real hard pedal and it takes forever to stop the car. i proceed to park the car on the street and put it in gear. i turn the key to shut it of and nothing. it keeps running. it has been 2 years since i had vacuum issues. i lift the hood and hit the STOP button. i start the car up and drive it slowly around the neighborhood and keep applying the brakes...still does it. then on like the 5th try, the brakes kick in. that was 3 weeks ago and the problem never resurfaced. Now i have 4 new pads, rotors and calipers, new brake line, new vacuum hoses and connectors. checked the fluid and thats fine.

only thing that i have noticed is that when the temp on the climate control is set to minimum, it still seems hot for a long while. (i also have a rebuilt control panel, receiver drier and temp sensor). the ac was switched to r1341 with all the new fittings. the only thing left is a new compressor as mine i gues leaks (420.00). when i switch the ac, i do not hear the compressor kick in. the mechanic may have diisabled it until i had it done is my guess. so that i would not have done damage. so what do you think? anything tied together? seems odd. this car is like "christine" in the fact its alive. when i contemplate a newer one, she acts like a brand new car..not wanting to piss me off. its weird.
 

·
Registered
1985 Euro 300TD Turbo, 1983 Euro 300TD turbo, 1979 Euro 240TD and 1981 300D converted to euro.
Joined
·
2,700 Posts
How old is the vacuum pump? And your brake booster might be bad....mine did the same thing and it was the brake booster..... i used the one off my old 77 and its been fine sence. If the vacuum pump is going then just get one at a junk yard coz 9 times out of 10 they have already been replaced.
 
1 - 2 of 2 Posts
Top