Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
'84 300D/ dakota benz trk. Sold... miss it. "88 260E '91 190E 2.6 '89 Volvo 240DL "85 300D
Joined
·
1,252 Posts
Discussion Starter #1
you all may have saw my post about eating crow due to jetronic. well after many days of absolute frustration, the gremlin was found. bad coil!
we had spark, fuel, compression, and accurate timing. but no start.
after consulting with jayare, IE.. the 103 "masta" i followed his instructions and now have a fine running benz for the wife again.
i had spark, it just wasnt hot enough. many, many thanks to jayare, augapfel, and others i may not remember, for their input. if not for them, i would have taken the head off for nothing.
one good thing from all this, i have learned so much about jetronic in this time. its a fine system. i took apart one of my fuel distributors totally just to see how it all works. its really not that complicated at all. makes sense to me. thanks again to all of you on benzworld. this forum itself is a invaluable tool!
 

·
Registered
1987 300TD - 1981 300D - 1990 190E 2.6 (Non Running for Sale) - 1993 190E 2.3
Joined
·
285 Posts
ROugh idle

this wasnt ever causing an inconsistent idle was it? I am STILL having that after a full tune up, Idle Control Valve cleaning (plus replacing hoses to it). Ignition coil may be my resolution?
 

·
W124 Moderator
86 190E 2.3L 16V, 2 95 320TE's, 02 S500
Joined
·
12,662 Posts
The coil won't be your solution. You don't have a coil on a diesel. If your idle speed is floating around, the usual suspect is a bad OVP relay. Do you know if yours has been changed? Also, you could get lucky and have a blown fuse in the OVP.. If yours is a later replacement unit, it will have two 10 amp blade fuses under the cap. OEM or early replacment units have a single fuse. At least this is the general case with gas powered motors.

Good Luck,

Jayare
 

·
Registered
1987 300TD - 1981 300D - 1990 190E 2.6 (Non Running for Sale) - 1993 190E 2.3
Joined
·
285 Posts
Gas

I was not clear and my signature confused you. I am referring to my dads 1987 300E that I've been working on. So what do you think? Bad coil? Full tune up improved a lot. Fuel filter change, air/gas adjusting but still a idle problem. Good after 2000 Rpms or so.
 

·
Registered
'84 300D/ dakota benz trk. Sold... miss it. "88 260E '91 190E 2.6 '89 Volvo 240DL "85 300D
Joined
·
1,252 Posts
Discussion Starter #5
mine was doing the exact same thing. above 2k ran fine until it finally quit. i DID have wild idleing etc. follow jayares lead on whatever he tells you. but mine did just like your dads.
 
1 - 6 of 6 Posts
Top