Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Premium Member
1999 S600 Sedan, 1999 S600 w/ 4-pl seating, 1995 S600 Coupe, 2-1992 600SEL's, 2002 ML55, 1998 SL600
Joined
·
2,401 Posts
Welcome!

Tell us more: How did you get the car? What did you pay for it, how many miles on it, have you done any work to it???
 

·
Premium Member
M120, M119, W126*2 + Silver Avantgarde wagon
Joined
·
4,718 Posts
Looks good - and welcome. MAVA is one of the tech Gods here and Stryker is the unsurpassed Master of collections...

Now to help you: - Have you replaced the double TT behind the firewall yet? (Martine the 320 has that as well right?)

You need to replicate rubber double TT preferably with Aluminum, or at least with a new one and check your engine mounts. When they get compressed it puts pressure on that double Tt and when that blows so does you engine.

1999 is a good year... I have one of those too, as well as 1998...
 

·
Moderator
93 SL500, 95 SL320, 96 S320, 98 S500, 2002 E320 4Matic Wagon & A little 91 5.0 FORD Mustang
Joined
·
7,949 Posts
Looks good - and welcome. MAVA is one of the tech Gods here and Stryker is the unsurpassed Master of collections...

Now to help you: - Have you replaced the double TT behind the firewall yet? (Martine the 320 has that as well right?)

You need to replicate rubber double TT preferably with Aluminum, or at least with a new one and check your engine mounts. When they get compressed it puts pressure on that double Tt and when that blows so does you engine.

1999 is a good year... I have one of those too, as well as 1998...
Yes, I forgot to mention tee....



What do you guys think of my 1999 S320 lwb.
Here is the post on the heater tee just did it not to long ago:

http://www.benzworld.org/forums/w140-s-class/2991553-what-hell-did-i-break-newbie.html#post17445247


Martin
 
1 - 8 of 8 Posts
Top