Mercedes-Benz Forum banner
1 - 6 of 6 Posts

·
Registered
1983 380SEL
Joined
·
470 Posts
Discussion Starter · #1 ·
Hello,

On my 300td, the glow plug light won't come on anymore and the car just keeps cranking and cranking but will not start!

There is 12v going to the glow relay and to both sides of the glow relay fuse.

Does anyone know if the relay could be bad? When the glow plugs are bad, it usually blinks.

Thanks!!
 

·
Registered
'84 300D/ dakota benz trk. Sold... miss it. "88 260E '91 190E 2.6 '89 Volvo 240DL "85 300D
Joined
·
1,252 Posts
if it all checks out under the hood, could simply be the bulb in the cluster...
 

·
Registered
2013 MINI Copper S Clubman, '84 300CD-weekend car
Joined
·
10,152 Posts
Check the resistance using an ohm meter, one or more may have finally burned out.
 

·
Registered
'84 300D/ dakota benz trk. Sold... miss it. "88 260E '91 190E 2.6 '89 Volvo 240DL "85 300D
Joined
·
1,252 Posts
agreed, on mine when glow plug light quit, engine wouldnt start either, strip fuse was burned out. i made a jumper wire until part arrived.
 

·
Registered
1983 Mercedes 240D, 1998 Audi A4 Quattro
Joined
·
171 Posts
Could be the glow plugs or the relay. I had a similar experience and tested all glow plugs..found them OK and then replaced the relay and everything was good to go again. I got a used relay for about $40 off ebay. You can get a relay plus 5 plugs for about $120 for the new style bosch relay. Check out the articles on Dieselgiant.com for better descriptions.
 
1 - 6 of 6 Posts
Top