Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi Everyone,

I am new to these forums, so your patience and help is required. I have 2007 GL450 which when parked goes really low on all the sides, sometimes it doesn't go low at all, but sometimes it will be the front driver side only and sometimes it will be both front and rear driver side. Everything goes back to normal when it's started and running. What's going wrong here and what precaution or recommendations are suggested?

Thanks a bunch
 

·
Registered
2008 GL450 Black
Joined
·
20 Posts
It sounds like you have air bag leaks.

They are common to leak on GL's at 50,000-75,000 miles. Replacement bags can be purchased from Arnott Do a search on this site for them. Good product, at reasonable prices. They come with really good instructions too. Most people or any shop can change them out. I just did the rears on mine last week, in my garage with two floor jacks, some stands and basic tools. The front are more involved, but still fairly straightforward

When you start the motor the air compressor comes on and airs up the bags while you are driving. They are probably leaking even when driving, causing the compressor to cycle constantly.

Change your bags soon, or you may end up needing a compressor as well.

You can do a search on this forum about "air bags" and get all the info you need
 

·
Registered
2008 GL 550, 2012 C250
Joined
·
73 Posts
Hi guys,

Yep, this happened to me. I scheduled an appointment with the dealer two weeks ago. I have an extended warranty so it was covered. Both left front and rear struts had to be replaced. Before I go to my appointment it wouldn't even lift back up while driving. It was very annoying and made driving slightly difficult. Fortunately this was only for two days. I pick it up on Monday.
 

·
Registered
Joined
·
1 Posts
Hello! I am new to this site, and a first time Mercedes owner. I am partial to BMW, as I have an M6 convertible. As BMW does not make any SUV's with a third row seat, my wife suggested a GL450. Im wishing I would have read up on them, before buying a 2007 GL450, with 48,000 miles. Not 5 minutes after pulling away from the used lot at the local Benz dealer, from where I purchased it, the check engine warning went on. It was an $800 fuel injector repair. Now, the front driver side sags down when the car is off, but not always. It always goes back up when started. I am guessing (after having read this forum), that it is the front strut. The dealer wants $1,500! I am seeing that I can purchase a remanufactured one, for about $500. Anyone ever replace it? I am very mechanical, but am a bit nervous about working on this car. Any input would be appreciated. Thanks.
 

·
Registered
2007 GL 450, 2001 ML430 (traded-in), 2003 BMW 325i
Joined
·
22 Posts
Arnott Industries provides excellent instructions on how to replace these on your own. I just did the passenger side rear and it was simple. Hardest part was putting the wheel back on. I've read that the fronts are more complicated and do require a gear puller but from the looks of it, it is something I will be tackling the fronts when they go.

As to your hesitancy on working on "this" car I understand. However, if you feel mechanically inclined, this repair is not super complicated to leave to the dealer in my opinion. I leave the ones requiring the speciallized computer and analysis equipment to the dealer.

You can do it with the help of this forum and in this case, Arnott Industries instructions.
 
1 - 6 of 6 Posts
Top