Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
driving it home to Qld 600miles,
trans appears not to be changing into top gear.
tacho is showing [email protected]

yet Im getting 10.1 kms per litre
or 22mp usg/ 28mp imp g
maybe the tach us faulty?
what do you think?

Got a long trip ahead of me.
 

·
Premium Member
Joined
·
5,450 Posts
For 1989 model year that transmission started out in second gear and shifted 2-3 and then 3-4. 4th is straight thru - no overdrive so highway revs will be high.

Tho not as high as you are experiencing. At 80mph with my 88 300E I was seeing 3500 RPMs. I think your CE will have 3.27 gears vs the 3.07 in my sedan but still...

Pull over and stop, accelerate moderately and listen/feel the upshifts. There should be two of them.

Does the shifter feel sloppy? There shouldn't be any play in the control lever. Worn/missing plastic bushings are a common problem. Point being that you may be in "3" instead of "D" So check each detent position coming back from "P" to be sure you're in "D"

Good luck. I was in a similar situation just a few days ago.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
my 300D has exactly that worn bush in the shifter so I know what you mean
However thats not the case here.
there is a small black plastic switch to the left of the auto quadrant with an E
When I tried to push it forward to E it came adrift, had been stuck with black goop
with the switch now gone Ive pushed the switch bit forward but the revs are the same.
Thought it may have been an O/D switch....E for economy?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
also actually is revving quite high in Park, can hear it.
Something with throttle cable at throttle body prevuous owner mentioned he been trying to adjust it.
Its morning now so gonna ask my sister (stopped at her place en route home) if she has any tools so I can get the air filter off to see what adjuzments and lubrication I can do.
Im stopped at Nabiac now.
Help!!
 

·
Registered
Joined
·
940 Posts
Whats the rev counter showing at tick over ? You do have adjustment on the throttle cable ? And you can get to it without removing the air box. If You find it is tight , look for a nylon nut on the cable,, lift the cable to see if it has any free play,, if not ,,then slacken off the nylon nut till it is easy to lift the cable inner with your finger not a lot you need free play in the cable so that the throttle quadrant can rest free on the end stop ,. .Also check out the small micro switch just to see if that works as it should press the end of the contact gently you will hear a slight click if it ok .To carry out the last check on micro switch you will need to remove air box.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Lubed all the linkages and it came good, as I was getting 10kpl I assume it was in 4th and tach was crazy!
pushed on north filled car up at next town and 8kpl , still not too bad, had a lot of winding roads with uphills to traverse so selected 3rd and it was definitly 3rd...once back on the open road sat on 100 kph for a while then 110kph then then the tach went right through the red into the clock!!! wasnt overevving though.
then a lurch and went into false neutral car slowed and I put in 3rd and it picked up, back into 4th, it was ok for a few minutes then sick again, engine oil light came on so I stopped.
checked oil it was half between add and full so ok.
Rang a trans place near home as I know the guy well.
He said though threyre bulletproof when theyre shot theyre shot!!!
after half hour and considering I was 15 kms from nearest town I pushed on after half hour rest stop.
up a very long hill, went neutral on me coupla times but I coaxed it over the hill on a wing and many prayers...then it was mostly downhill run into town.
Im not gonna try to get any further as its hundreds of miles.
Local truck co. locked it in thier yard for me, I asked anyone had a cheap car the old guy behind counter said take my Triton ute drive through town to local car sales yard and tell Peter that John sent you..
Peter had Subaru Forester that its 90 yr old driver had put in reverse by accident and backed through the front window of the local hardware store then handed her license in...$800 and he also lined up a car carrier to truck my benz home in next few weeks for $500...
So Im making best of the bad situation, $45 room in country pub about to eat Chinese.
Wonder what to put in the Benz?
LS1 maybe....
 

·
Registered
Joined
·
940 Posts
Good read hope you get it fixed and get home safe .But did you check the auto box atf fluid level the right way . After engine is up to temp and left running you service brake on - you put the car in to Park pull the dip stick with the engine still running wipe with a lint free rag , insert the dip stick again and then check the level .
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
yeah I know how to check it, took 400 mls
Trans expired and had to buy a cheap subaru to get me home
Cars locked in a trucking companys yard till I figure out what to do with it.
 
1 - 9 of 9 Posts
About this Discussion
8 Replies
3 Participants
Motorbikerx
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top