Mercedes-Benz Forum banner

41 - 48 of 48 Posts

·
Registered
Joined
·
17 Posts
Does anyone know the difference of the color codes on front oem springs ? I’m looking to replace my front springs and noticed with replacement options there’s different color codes on different front springs? Do any change in hight difference slightly? Thanks for any help!
 

·
Registered
Joined
·
3 Posts
Hi guys. Need help.
Not long ago I had to replace the center drive shaft rubber boot as it was torn. Unfortunately I didn't give it a serious attention and just replaced the rubber and installed the shaft. But later found out that it has to be balanced. Its obvious that the balance is lost.

Pls advice me how to balance it by my own with minimum trouble.

The truck is 2001 G500.

Thank you
Hello everyone,,
I'm currently thinking my 2004 may need a new drive shaft because of a cabin vibration at 40 mph and at 60 mph. I replaced drag link, balance tires, and four wheel alignment. My G has 260K and I really need help.

Thanks for your help!




Hi guys. Need help.
Not long ago I had to replace the center drive shaft rubber boot as it was torn. Unfortunately I didn't give it a serious attention and just replaced the rubber and installed the shaft. But later found out that it has to be balanced. Its obvious that the balance is lost.

Pls advice me how to balance it by my own with minimum trouble.

The truck is 2001 G500.

Thank you...
 

·
Registered
Joined
·
3 Posts
Hello Everyone,
I'm new to posting here. I have a 2004 G500 with 260K miles on it. I"m getting a bad vibration in the cabin when I reach 40 to 55 mph. its load and I really need to find out what is bad. I've replaced drag link, gotten alignment.
Thanks for your help!
 

·
Registered
96 G300DT
Joined
·
1,987 Posts
At 260K, chances are that it is the center shaft finally giving out. Just be sure that the tires are all perfectly balanced. Though to be honest they usually start bouncing around 60+ mph.
 

·
Registered
Joined
·
3 Posts
Hello Alan,
Thanks for your response, I've balanced the tires. The roaring starts at 40 mph and goes away and comes back at 60 mph. So if I change the small propeller shaft this vibration should go away. I've also been searching for why my truck goes into a misfire and check engine light comes on when ever my gas tank reaches haft tank. I go to gas station fill up and drive a full cycle and light goes out. This has been going on for about 1 1/2 years. Someone side it was the sending unit, but I have yet to find someone else that has experienced this problem.
 

·
Registered
96 G300DT
Joined
·
1,987 Posts
That shaft is way past its sell-by date.
The sender is an unlikely culprit. How recently has the fuel filter been replaced? With the tank full you get a bit of help pushing through the filter. Again, if not recently replaced, worth a try.
 
41 - 48 of 48 Posts
Top