Mercedes-Benz Forum banner

1 - 20 of 21 Posts

·
Registered
SL55 (2002)
Joined
·
25 Posts
Discussion Starter #1
Hi, My SL55 (2002) has developed a loud noise coming fom the fuel pump, the best way to describe the noise is like a motor bike reving!

Unfortunatley I've changed the pump but it did not rectify the noise:crybaby2:
The noise doesnt happen from cold and takes about ten mins of running before it kicks in, it sounds if the pump is struggling for some reason?
I've had a look at the diagram for the fuel system and I see it contains a fuel pump control unit?, a pressure sensor and a pressure regulator,
Has anyone else had this problem? any help greatly appreciated!!:)

P.S I changed the fuel filter last year
 

·
Outstanding Contributor Always Remembered RIP
216 with everything. 2002 SL500 with everything. 2009 SL500 with everything.
Joined
·
6,543 Posts
I have never heard of this one at all, can you actually feel it in the tank
 

·
Registered
SL55 (2002)
Joined
·
25 Posts
Discussion Starter #3
You can feel the vibration by touching the fuel pump, so i think its the pump making the noise but unable to identify whats causing the pump to make it, Im guessing fuel starvation or perhaphs over pressure in the system?? At a loss really, the only other thing that might be related is that over the last six months if i put more than half a tank of fuel in the car i would get a hissing sound from the rear wall, like an aerosol can going off, this noise would be constant till the tank level dropped or i turned right while driving??, This noise has now stopped.
Ive tried removing the sender unit and the fuel cap when the revving noise is there encase theres a vacuum but made no difference?

Any advice greatly appreciated
 

·
Outstanding Contributor Always Remembered RIP
216 with everything. 2002 SL500 with everything. 2009 SL500 with everything.
Joined
·
6,543 Posts
I will do a search, but I do not feel hopeful, I was also thinking a loose baffle but this did come till dec 02
 

·
Registered
SL55 (2002)
Joined
·
25 Posts
Discussion Starter #5
just a quick update,

Took the car into the dealer and they said the pump is running at 14v continously, should be in the range of 5v to 12v ? so they have diagnosed the pressure regulator as faulty. They believe theres too much pressure in the system as the pumps running flat out all the time causing it to struggle against the back pressure.
The parts going to take seven days to come from germany, worryingly I asked the service guy what the fuel pump control unit did and he said he didnt know it had one !!!
Cost is £160 + vat for regulator and £400 labour!!

Does anyone know where the regulator is located? Is it a do-able job at home ?

cheers
 

·
Registered
Joined
·
5 Posts
Fascinating! I have the exact same problem with my SL55 - sounds like there's a small motorcycle revving in the boot. 7sisterSL55, I'd like to send you a recording I made on my phone to see if it's the same noise as yours. Can you PM me your email address please?

My car developed severe problems yesterday, loss of power accelerating beyond about 50mph, MB sent a man out to have a look who diagnosed fuel pressure problems, so car was trailered to the dealership.

Really sick of this car. Second recovery in as many months, first was a corroded ABC valve. It's a never ending list of failures, costing a fortune and it's no surprise the car has depreciated from £96k when I bought it in 2002 to £14k now, only 19k miles on it.

Edit: Turns out the crankcase breather hose had developed a leak leading to the air metering being all over the place because the leaky pipe was letting air in, bypassing the air mass flow sensors. Still £240+ to fix.
 

·
Registered
Sl55amg
Joined
·
12 Posts
Noisy fuel pump??

Right guys have seen this asked before with no definitive answer.bought my car in December and so far so good spent about 1k on getting her right and preventative maintenance.just the abc to flush and new 3 micron filter to do.however I have a very noisy fuel pump. Or do I? Is it the regulator? Stops making the noise briefly when making right turns???any advice greatly appreciated.tanky
 

·
Registered
00 SL500 SOLD, 05 SL600 Sport, 09 Silverado 4x4 LTZ,SOLD '15Silverado LTZ 6.2 8Speed John Deere 318
Joined
·
1,781 Posts
early 230's had a problem with the baffle in the tank. It may be hitting the pump and making it noisy!!! Your profile is not complete so I can't tell what Yr. your car is, Sorry!!!
 

·
Registered
Sl55amg
Joined
·
12 Posts
Nice one thanks for that.there are a few threads like that on other forums but the op don't let us know any outcome!
 

·
Registered
2003 SL500, 2000 S500
Joined
·
364 Posts
...I have a very noisy fuel pump. Or do I? Is it the regulator? Stops making the noise briefly when making right turns???
While the engine is running the pump is continuously powered by battery voltage through a relay controlled by the engine management ECU.

The fact that the sound disappears in a right turn suggests to me that the noise may have something to do with the pump mounting -- not likely, but worth a look.

The fuel pressure regulator and filter are combined into a single unit located just downstream of the pump. If the filter is partially clogged the pump faces increased back-pressure, and perhaps this could cause it to run louder.
 

·
Registered
Joined
·
385 Posts
The fuel pump is outside of the tank, mounted on a bracket in front of the rear axle.
It can't be seen without putting car on a lift.
I wonder if it's bracket (2304780540 ) or insulator (2304780282) are damaged/loose?
 

·
Registered
Joined
·
2 Posts
Fascinating! I have the exact same problem with my SL55 - sounds like there's a small motorcycle revving in the boot. 7sisterSL55, I'd like to send you a recording I made on my phone to see if it's the same noise as yours. Can you PM me your email address please?

My car developed severe problems yesterday, loss of power accelerating beyond about 50mph, MB sent a man out to have a look who diagnosed fuel pressure problems, so car was trailered to the dealership.

Really sick of this car. Second recovery in as many months, first was a corroded ABC valve. It's a never ending list of failures, costing a fortune and it's no surprise the car has depreciated from £96k when I bought it in 2002 to £14k now, only 19k miles on it.

Edit: Turns out the crankcase breather hose had developed a leak leading to the air metering being all over the place because the leaky pipe was letting air in, bypassing the air mass flow sensors. Still £240+ to fix.
How are you? I guess that my SL55 AMG 2005 is doing the same noise, can you send my your recording just to know if my car have the same problem? Thanks in advance
 

·
Registered
1999 SL600
Joined
·
12 Posts
Apologies for digging up an old thread but did anyone get to the bottom of this? Have exactly the same symptoms on an 03 SL55. From reading around its either pump, pressure regulator or pressure sensor. Surely someone must have cracked what fix this requires? Pressure regulator or sensor would get my nod before the pump but could use confirmation.

Thanks in advance.
 
1 - 20 of 21 Posts
Top