Mercedes-Benz Forum banner

21 - 27 of 27 Posts

·
Registered
Joined
·
15 Posts
had the same problem

so i changed my filter , filled it up to the very top with ATF.
it start right up ... then stumbled a little then cleared up. then I noitced the fuel filter nut at the top of the filter was leaking a little so i shut it down, and snugged it. then the darn thing would not start again.
what a pain in the but
here is the tool list
1) 17 mm wrench
2) Battery charger
3) lots of time
my little white purge knob feels very loose when you pull it up and down , almost like if it has some type of seal or oring it is gone.
i finaly got it to pump but not a lot. cracked fuel line nut at top of filter.
and then crack a few injectors then it start , had to hold foot on the floor on the fuel pedal and she final started.
 

·
Registered
1984 300D 375,000 miles 1996 e300d 266,000 miles 1983 300SD 174,000 miles Ascot Grey
Joined
·
453 Posts
if your primer pump is white plastic,and requires unscrewing, you should replace it with the bosch black pump. Cheap and easy. Those pumps are a big source of air being allowed in to the system (as noted earlier in this thread), which makes it hard to start after changing filters. It's a 5 minute job if you have a 17mm crow foot wrench. Can be done with a straight wrench, but just barely.
 

·
Registered
Joined
·
15 Posts
pump

so it just screws in were the factory one is ?
also wonder why they both say wont work with veggie oil ,etc ?I was plaining on running a blend
also thought about putting a eletric one in with a tie and a check valve so you can just flip a switch and pump away
 

·
Registered
2013 MINI Copper S Clubman, '84 300CD-weekend car
Joined
·
10,152 Posts
Yes, the white one unscrews and the new one screws in, be sure to remove the old copper crush washer and replace with the new one that comes with the new primer pump.

They may just be covering their backside concerning veg oil.
 
21 - 27 of 27 Posts
Top