Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
'09 E350 4-matic sport, '83 240D 4-speed (sold), '77/'78 450SLC (junked), '81 500SLC (junked)
Joined
·
845 Posts
Discussion Starter #1
I tore apart my entire front suspension today. I pulled off everything except the steering damper and the tie-rods. I would have put it all back together today but I got sent two left UCAs. I gotta track down a right one tomorrow. Anyway, I also realized that the Hayne's manual doesn't have crap for torque specs. and I can't figure out what the parts are that it does give specs for.

I need pretty much all the front susp. specs.:
-lower ball joint nuts
-large upper control arm bolts (that go through the body)
-big idler arm nut (that goes through the bushing)
-tie rod end nuts
-track rod end nuts
-guide rod mount bolts
-brake caliper bolts
-lower control arm eccentric bolt
-guide rod to lca bolt

I'm putting loctite on everything that looks like it had some on it before. But off the top of my head I can only think of two places that had it: the guide rod mount bolts and the spring perch bolts. Anything else?

What a day....
 

·
Registered
money pits of various forms
Joined
·
5,885 Posts
GNT with some blue loctite. The only ones you really have to worry about overtorquing are the UCA bolts on the sway bar and spindle.
 

·
Registered
2013 MINI Copper S Clubman, '84 300CD-weekend car
Joined
·
10,152 Posts
Not sure about loktite that wasn't there before.

In the pic at the very bottom is a definition for 2nd version starting in 1977, so that info is on the chart.
 

Attachments

·
Registered
'09 E350 4-matic sport, '83 240D 4-speed (sold), '77/'78 450SLC (junked), '81 500SLC (junked)
Joined
·
845 Posts
Discussion Starter #4
Thanks.

I finished up yesterday. The steering is a lot tighter (and it wasn't so bad before) but the ride is a lot harsher. Hopefully an alignment and a bit of time will take care of that.

I'll comment more on ride quality and handling after I drive it for a bit.
 

·
Registered
'09 E350 4-matic sport, '83 240D 4-speed (sold), '77/'78 450SLC (junked), '81 500SLC (junked)
Joined
·
845 Posts
Discussion Starter #5
I realized that I put the shock covers under the plate and rubber mount thing instead of over, so I guess I have to redo those. Not a big deal.

Also, I'm hearing some clicking from the front left wheel under hard right cornering. I'll try tightening the axle nut a bit and see if that helps, otherwise I guess I need a new bearing.
 
1 - 6 of 6 Posts
Top