Mercedes-Benz Forum banner
1 - 14 of 14 Posts

·
Registered
2000 e320 4matic Sedan
Joined
·
239 Posts
Discussion Starter · #1 ·
well my ffront passenger seat controls do not work correctly anymore, doesn't matter which way I want to adjust the seat cuz it just goes forward.....anyone know how I can fix this problem or if there is a way to reset the seat controls?

I don't know if this may be a contribution to the problem but my srs light is also on, but the seat controls weren't working before that issue
 

·
Registered
E320 V6 1998, E320 CDI 2002 and V230 Ambiente auto 1998 & E430 210kmiles (UK)
Joined
·
55 Posts
Hi,

I had similar problem on my e320 1998, the backrest would only move forwards. I just pushed the controls in hard .. not to hard that it breaks, and since has been working properly. It's not a permanent solution !
 

·
Registered
1997 E320 w210 1995 Cadilliac Eldorado w/Northstar 1991 Fleetwood Brougham
Joined
·
150 Posts
Theres a "BOOK" way of resetting seats by moving seat positions to the end of each movement then hold the control for a few seconds. This didnt work for me. I took a can of Dust Off and attached the spray nozzle, sprayed along the outline of the controls, and havent had a problem since. This is probably not a permanent fix but it worked for me!
 

·
W210 Moderator
99 E320
Joined
·
5,347 Posts
yes, try Step's suggestion first. if adjusting the seat travel to the stop(s)
doesn't do the trick, consider the info on the attachment. it simply diagrams
the seat switch as one of the possible causes....not necessarily the origin
of the problem you currently are encountering.
 

Attachments

·
Registered
2000 E320 Sedan
Joined
·
69 Posts
I have the problem as well. I also had a problem with the BAS/ESP light coming on and off. That one finally came to a head when the car would not shift out of gear. The problem was a bad brake light switch. I had that replaced so no more problems with the BAS/ESP light. But ..... the problem with the seat only going forward is gone as well. Not sure if there is a connection.
 

·
Registered
Joined
·
4 Posts
this happens in my 99 e320 almost everyday, my fix is to turn car off, open passenger door, with the door open i can correctly control the seat, close the door turn key and drive away.. . . the controls work normal most of the time, problem tends to happen when trying to lay back too far then backrest starts to move only forward.
 

·
W210 Moderator
99 E320
Joined
·
5,347 Posts
for the hell of it, dbl check the runner. see if you have dropped coins or
paper clips etc which may jam along the track at a certain point.
 

·
Registered
2000 E320 Sedan
Joined
·
69 Posts
The dealership reset my controls and it worked for a few days. Now it does the same thing. For my purposes I have solved the problem by actually using the three memory setting for the seat, one for me, one for my wife and one all the way back. The memory buttons have never given me a problem so I now dont mess with the other switches on it. Dealership quoted me something like $500 to replace the motor for the driver side seat. No way.
 

·
Registered
1997 E320
Joined
·
18 Posts
I was having the same exact issue & used the memory buttons as a work around.
But now the passenger seat will no longer raise to back past half way up. Even with the
memory button. I'm gonna take out the switch and see if I can repair it with some solder
like suggested. Will post results.
 

·
Registered
1999 Mercedez Benz E320 4-Matic Sedan
Joined
·
86 Posts
I had problems with the seat switch on my 1999 e320 4matic. Direction of movement opposite from switch direction; would not go back up was down etc. I removed the switch from the door and carefully cleaned it with elec. spray cleaner and gently scraped oxidation off the board and solders. Problem solved. did the same with my trunk release switch. Seems like moisture takes its toll over the years and corrodes the board shorting it out.
 

·
Registered
1999 E300TD: 382,000 kms.Parked for the winter. 2002 Golf TDI, 441,000kms, winter beater
Joined
·
87 Posts
Thanks for posting guys,

I had the same problem with my seatback control on the passenger side, the backrest would only move forward, memory was OK in both directions. I cleaned the PC board and switches with a liberal amount of contact cleaner while brushing the PC board clean with a soft bristled brush, and exercising all switches.

Works like new now.

Cheers
 

·
Registered
2005 E320 wagon
Joined
·
2,134 Posts
A 2003 E320 sedan is a W211 so you might get better advice in the W211 forum. A 2003 E320 wagon is a W210. I checked my ‘98s and there’s no power to the seats with the doors closed and the key out. Of course that could be only the switch panel that isn’t powered.

Sixto
98 E320s sedan and wagon
 

·
Registered
1998 E320 Sedan RWD 150k mi
Joined
·
206 Posts
I'll put in my 2 cents. Had this problem several times and first tip is make sure you program your preferred settings in the memory, that way when the controls go nuts you can just use one of the memory buttons. Also, believe it or not I've had luck just kind of banging the buttons lightly with a fist or whatever. That sounds so laughable but it often has worked for me, but be careful not to do it too hard or you can brake the plastic clips and the whole thing will just fall into the door, no fun.
 
1 - 14 of 14 Posts
Top