Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Mercedes Benz W140 (300SE) 3.2L 1991 Petrol. Import from Japan with Lorinser Mod.
Joined
·
649 Posts
Discussion Starter #1
My head light low beam of the left side is not working? Parking light is working and high beam is working thought?!! What could be the reason.?? I have big doubt that it is a fuse l Your kind help is appreciated.:surrender:
 

·
Registered
Mercedes Benz W140 (300SE) 3.2L 1991 Petrol. Import from Japan with Lorinser Mod.
Joined
·
649 Posts
Discussion Starter #3
but at the same time the left-right parking position light is not working too? It happened to me before 4 months, and now again it happened! I really need a reason. The headlight is not burned I saw it it is working fine, something with the fuses ... ???
 

·
Registered
85 300D
Joined
·
390 Posts
YES, its most likely IS a fuse. You have a left low beam, right low beam/ fogs, right high beam, and left high beam fuse (4 total for lights with RLB and fogs on one 16a). Twist your fuse a few times (NOT with light on, it will arc) and try again. If fuse is blown replace it, but the ends are probably corroded. If that doesn't work, then replace the light like someone said. This just happened a few weeks ago on my car before I put in all new fuses (best $4 you'll spend, get the copper ones though).
 

·
Registered
Mercedes Benz W140 (300SE) 3.2L 1991 Petrol. Import from Japan with Lorinser Mod.
Joined
·
649 Posts
Discussion Starter #7
OK guys thanks for the help, I checked the fuse but they were all fine, and I replaced the bulb and it worked! When I looked at the old bulb nothing seemed to be burned??? Could be something internal...

Anyway thanks for the advise about the fuse DZL I will be doing this (God willing) soon. My fuse box looks old and durty, I think it is time for a good cleaning and replacement of fuses.
 

·
Registered
'82 300D
Joined
·
1,279 Posts
Haroundb said:
OK guys thanks for the help, I checked the fuse but they were all fine, and I replaced the bulb and it worked! When I looked at the old bulb nothing seemed to be burned??? Could be something internal...

Anyway thanks for the advise about the fuse DZL I will be doing this (God willing) soon. My fuse box looks old and durty, I think it is time for a good cleaning and replacement of fuses.
I had the same problem with the left side parking light. I cleaned the fuse contacts, and all was well again. Oxidation and corrosion will halt the flow of electricity.
 
1 - 8 of 8 Posts
Top