Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
1997 E320 134,000 miles black on black
Joined
·
42 Posts
Discussion Starter #1
When I turn on my front defroster it makes a horribly loud bellowing noise. Do that mean I have some flaps not shutting somewhere? or is it normally loud?
I have not had to use the defroster until now so I don"t know what normal sound is.

Thanks,
Jason
 

·
Banned
1999 E300 TD
Joined
·
2,045 Posts
When you turn the defrosters off and then redirect the air to the various positions do you hear similar air noises.

PS: The defroster flaps are the only flaps that are open when there is no vacuum present.

It's a safety feature and ensures that the widnshield can be kept from fogging even if there is a malfunction in the vacuum system.

Think of it----------your an Okie freezing his/her butox off with a defroster vacuum element problem----------now that's a defroster issue----flap closed!!!
 

·
Registered
1997 E320 134,000 miles black on black
Joined
·
42 Posts
Discussion Starter #3
When air comes out of the rest of the vents I just hear air blowing, but we I turn it to defrost it sounds like you are using an air compressor to put air into a balloon that has the end cut off.
 

·
Banned
1999 E300 TD
Joined
·
2,045 Posts
When air comes out of the rest of the vents I just hear air blowing, but we I turn it to defrost it sounds like you are using an air compressor to put air into a balloon that has the end cut off.
From this point, all I have is more questions to help you localize the reason for the noise---like

what about the impacts of fan speed

is the noise constant or does it change over time

remove the dust filters and run the system

when was the last time you changed your dust filters

are all the other flaps working correctly

and I am sure that others wil have additional suggestions

good luck
 
1 - 4 of 4 Posts
Top