Mercedes-Benz Forum banner
1 - 5 of 5 Posts

· Registered
1999 S500 1993 300e 2.8 1991 190e Sportline 2.6 5sp
Joined
·
142 Posts
Discussion Starter · #1 ·
This weekend my wife and I took a trip to northern California, and I noted (twice!) that after being parked, the emergency brake set, and in park, that after I backed out of a parking space, I would hear a very loud "thump/bump" noise coming from the front end. This is almost as if the front brakes were stuck forward, and when I backed out they became unstuck. I know I wasn't over a parking concrete-thing (I don't know what they are called!) and I did not ride over anything. The thump is strong enough, that I feel it through the steering wheel column. My wife was concerned that the front brakes were loose and falling apart. Has this happened to any of you guys? Should I be concerned about this? Is there something wrong with the callipers and/or brake pads? These are fairly new.

Any advice would be greatly appreciated.[:0]

Thanks.- Joey
 

· Registered
86 560SEL
Joined
·
1,334 Posts
My guess is that they weren't installed correctly. Did you change the rotors too? Are th...

My guess is that they weren't installed correctly. Did you change the rotors too? Are they torqued tighten correctly.
 

· Registered
S320W
Joined
·
602 Posts
This weekend my wife and I took a trip to northern California, and I noted (twice!) that after being parked, the emergency brake set, and in park, that after I backed out of a parking space, I would hear a very loud "thump/bump" noise coming from the front end. This is almost as if the front brakes were stuck forward, and when I backed out they became unstuck. I know I wasn't over a parking concrete-thing (I don't know what they are called!) and I did not ride over anything. The thump is strong enough, that I feel it through the steering wheel column. My wife was concerned that the front brakes were loose and falling apart. Has this happened to any of you guys? Should I be concerned about this? Is there something wrong with the callipers and/or brake pads? These are fairly new.

Any advice would be greatly appreciated.[:0]

Thanks.- Joey
When you backed out, did you release the parking brake?
 

· Registered
1999 S500 1993 300e 2.8 1991 190e Sportline 2.6 5sp
Joined
·
142 Posts
Discussion Starter · #4 ·
As far as I know, before I bought the car, it had gone through a major brake service in wh...

As far as I know, before I bought the car, it had gone through a major brake service in which the rotors were replaced and new OEM pads were installed. In fact, I had my mechanic look at them and he said there were fairly new. I looked at the rotors and they showed hardly any wear.

Before I backed up, I did release the break. Sounds pretty scary when it happens...!

Joey
 

· Registered
86 560SEL
Joined
·
1,334 Posts
Perhaps you could check the emergency brake cable. Sounded like there's a delay on releas...

Perhaps you could check the emergency brake cable. Sounded like there's a delay on releasing the brake. I am only guessing.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top