Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter #1 (Edited)
Hey guys,

I just installed fog lights in lower opening on front bumper. I didn't want to install another switch to power them. I wanted to utilize AUX switch next to radio. Here is how I did it.

As we all know, there is plugged connector behind driver side headlight for push bar mounted headlights, I guess. It's controlled by relay k30 in fuse box. To activate that plug dealer has to activate it with Star diagnostic programming AAM module. Rear fog light is already activated and controlled by k29 relay in fuse box. In order to have both relays activated by same switch, just connect terminals on both relays. When aux light button pressed down to activate rear fog light front fog connector becomes active. I just stuck piece of wire between relay terminals and was done with it. Aux is only active with headlights on. The good part about it there is no need to go to dealer to activate aux plug and you never forget to shut down your fogs. Once headlights shut down fogs are off with them.

If anyone needs to have fog light AUX connector active, this is the simplest way.

Sorry for crappy pictures. Took them with my phone.

Happy motoring!
 

Attachments

·
Registered
Joined
·
3,197 Posts
Didnt know there was a seperate harness for fogs on the bull bar. Kinda cool. I have fogs in the headlights like most people....this free mod is one I have not done yet...guess I will get on this.
 

·
Purple Moderator
Joined
·
21,649 Posts
There is a wire set with two connectors held in right along the bumper. If you look around
you will see the two unused connectors.
The are there for the Hellas or PIAAs that would go on the factory brush bar/skid plate.

As long as you keep the wattage under 55w you can have both sets of fogs on the same
circuit. I have had them set that way for over ten years. Lots of light when the Hellas
are on with the headlights and the fogs in the headlight housing. It has saved me from
hitting deer out here in the country.
 

·
Registered
Joined
·
3,197 Posts
OK...so I followed these directions...as well as searched the other threads. When I completed this mod...the light on my fog light switch came on and stayed on after I took the key out and turned off the lights. I doubt that is supposed to happen. Anyone able to figure as to why??
 

·
Registered
Joined
·
135 Posts
Discussion Starter #5 (Edited)
OK...so I followed these directions...as well as searched the other threads. When I completed this mod...the light on my fog light switch came on and stayed on after I took the key out and turned off the lights. I doubt that is supposed to happen. Anyone able to figure as to why??
Hmm, I have LED tail lights. I connected rear fog LEDs to come on when I brake. So I have four brake lights come on on braking. Bright as traffic light :) Maybe because I don't have rear fog light connected to circuit I don't have a problem like yours. On the other hand, according to schematic diagrams, relays are controlled by ground sent by AAM module. So when one presses console switch ground sent to rear fog replay. By connecting jumper wire to front fog relay off rear fog relay, AUX connector receives power.
Did you jump left terminals closer to driver side fender on both relays? Maybe there is a short somewhere. I just checked my light and it works just fine- switch led comes on and off on pressing.

http://restoreyourmercedes.com/ML430 rear.JPG Rear LED tails picture. High mount stop light converted to two square LED boards.
 

·
Registered
Joined
·
3,197 Posts
Did you jump left terminals closer to driver side fender on both relays? Maybe there is a short somewhere. I just checked my light and it works just fine- switch led comes on and off on pressing.

http://restoreyourmercedes.com/ML430 rear.JPG Rear LED tails picture. High mount stop light converted to two square LED boards.
Yep...connected the same as you. I am stumped by it.

What wattage did you use for the LED conversion? I was thinking about soldering up and mounting a similar unit...but I was going to use 21 1W LEDs
 

·
Registered
Joined
·
135 Posts
Discussion Starter #7
Yep...connected the same as you. I am stumped by it.

What wattage did you use for the LED conversion? I was thinking about soldering up and mounting a similar unit...but I was going to use 21 1W LEDs
I used 2 pcb LED boards from superbrightled com. They sell LED boards with 1156 socket. I connected both boards into one socket.

I also replaced cluster lights with LEDs. Twist on LEDs don't fit so I disassembled them and solder LEDs directly onto cluster PCB. Check out my site in my signature below under w163 mods for high resolution picture. You might like the way cluster looks :)
 

·
Registered
Joined
·
3,197 Posts
You dont have a signature lol

I could use SBL lights...but I want the challenge of making them myself :) I'll let you know both ways.
 

·
Registered
Joined
·
6 Posts
I have the cutouts for the foglamps in the lower front bumper and the aux switch in the dash, can I add the lamps fairly easily? I wasn't sure if the connection would be there to connect to. Thanks.
 

·
Registered
Joined
·
1 Posts
Victor thank you for very useful advice. Worked on an ML 430. I was scratching my head tryin to guess why no voltage on front fog relay. Did not know it was programmable, why Mercedes includes the relay and fuse...,
 
1 - 10 of 10 Posts
About this Discussion
9 Replies
5 Participants
Kaspitas
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top