Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Had the dreaded DOE today and they failed me on the fog light, even though it hasn't had a fog light for 2 years,passing every time and all of a sudden it needs one! sorry little rant..
Any way seems the problem is the relay for the fog light.
I've had a mechanic look at it and even he doesn't know where it goes..
and he used to work for merc!
anyway if anyone could help, by telling me exactly were this relay is located that'd be deadly!
thanks

jon.
 

·
Registered
2011 316
Joined
·
171 Posts
Had the dreaded DOE today and they failed me on the fog light, even though it hasn't had a fog light for 2 years,passing every time and all of a sudden it needs one! sorry little rant..
Any way seems the problem is the relay for the fog light.
I've had a mechanic look at it and even he doesn't know where it goes..
and he used to work for merc!
anyway if anyone could help, by telling me exactly were this relay is located that'd be deadly!
thanks

jon.
Hi Jon

I did not think there was a relay for the fog light, but does the warning light up on the dash?

but as a quick fix, run a wire from the switch, and down to the rear light and it will get you through the mot, then look for the problem later.

Radiotwo
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Hi Jon

I did not think there was a relay for the fog light, but does the warning light up on the dash?

but as a quick fix, run a wire from the switch, and down to the rear light and it will get you through the mot, then look for the problem later.

Radiotwo
Yeah i didn't think so either...
no light on the dash but there is power to the switch ..
Might have to go with that wire option for sure ...

nice one man!
 
1 - 3 of 3 Posts
Top