Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
When driving the other night my lights started flickering and started shaking a little bit when coming to a stop sign I pulled over an turned it off an when I did the car had died i had to wait a couple minutes before the trunk would open to get a get jump after I jumped it back to normal no shaking an drived good the next day now the cel turned on an feels like it misfires bad and the light are flickering again. I have a new battery and new spark plugs installed a couple months ago no problems until now. What should I start to look at
 

·
Registered
1989 W124 260E
Joined
·
1,529 Posts
I Would first check the belts just to see if it is possible to turn the alternator pully . But If that is ok and no play, Check the output from the alternator . Most every time this problem crops up ,, its due to the regulator brushes in the rear of the alternator .If battery runs down , due to faulty regulator the car will shut down to save the information in the computer .
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I Would first check the belts just to see if it is possible to turn the alternator pully . But If that is ok and no play, Check the output from the alternator . Most every time this problem crops up ,, its due to the regulator brushes in the rear of the alternator .If battery runs down , due to faulty regulator the car will shut down to save the information in the computer .
No play in the belts I’m going to go the dealership In the morning and get a new voltage regular and will post back if it fixes or not
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Changed the regulator but now my key won’t click in the ignition I been had to wiggle it around for it to work since I got the car but now the key does nothing in the ignition
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Update car on the way to the dealer I’m lost asfar as the key unlocking the doors and doing nothin in the ignition
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Had to get a new key made and turns out it wasn’t the voltage regular my engine ground wire was disconnected
 
1 - 7 of 7 Posts
Top